9
$\begingroup$

I would like to make my textures visible in sunlight. I adjusted the exposure but that didn't help:

Texture turns white in sunlight

Right now when sunlight hits my textures they turn white. I want to be able to see the texture even in bright sunlight. Like in this image:

Texture remains visible in sunlight

By the way I am using a free HDR (downloaded from poliigon.com) to light the scene. Increasing the roughness also didn't help. Any help would be appreciated. Thanks.

PS The first image, excepting the HDR, is my work, the second image was downloaded from poliigon.com

$\endgroup$
26
+500
$\begingroup$

"I adjusted the exposure but that didn't help"... maybe you mean: I didn't adjust the exposure "enough".

"My textures they turn white"

But what is white anyway?

In the case of digital images, "white" is just the limit of what the display can deal with, when the data has reached the top of the scale: 1 or 100%. If you want detail in the highlights, those highlights should fall within that scale. Brighter values are ignored or "clipped".

How do I fix it?

There are many approaches:

The first step is to evaluate the brightness or "exposure" of the scene. Use the "False Colour" setting in the color management section to view how hot the scene is. Very bright values will be displayed in red, and "blown out" will be shown as white.

enter image description here

Or use the vectorscope on the Image Editor to see up to what point the highlights are being "clipped" (usually you can see a horizontal line at the top of the scale)

enter image description here

If you are lighting the scene with a HDR image, use the "strength" slider on the world/surface to bring the values to a point where the texture is not "blown out", or it falls within the limits of what is displayable.

Same scene but with lower strength on the environment texture:

enter image description here

Vectorscope and False Colour show that the highlights are not clipped anymore

enter image description here

enter image description here

The trade-off is that, in order to get detail on the highlights, the rest of the scene will go dark too. That is quite normal: it is hard to light a scene with a very large dynamic range, like the one you are showing, without additional lighting or re-interpreting the brightness values, or some other trickery. In real life, a photographer would need to add potent light sources inside the room to be able to capture detail in the highlights on the clouds, and the detail of direct sunlight in the room, plus the detail on shadows that are darker by several magnitudes. You could add some light sources to enhance or recreate the illusion of "realism".

Next image shows the same scene, with an area light placed where the direct sunlight illuminates the floor. Note that the area light illuminates only in one direction, and is set to be invisible to the camera using "is camera ray" on a Light path node:

enter image description here

A different solution would be to use the same HDR image to light the scene, and use nodes to make the camera see the same image at a different intensity in the background. As explained here: https://blender.stackexchange.com/a/113945/92768.

Or you can use the ASC-CDL node to change how the values of the scene are interpreted for the final image. As detailed in these links: https://blender.stackexchange.com/a/69615/92768 and https://blender.stackexchange.com/a/57927/92768

Here's the same scene again, with the original values that caused clipping, but interpreted through the Color Balance/ASC-CDL node. Using Power and Slope the high values were brought down to levels below clipping, and the contrast of the scene was modified to brighten the darker areas.

enter image description here

Additionally, blender has tools to interpret the values of the rendered image using one of the different "looks" on the color management section. Try a "low contrast" or "very low contrast" setting.

The last solution I will propose, is to generate two or more different images, one for the interior of the room with the proper light values, and one for the exterior that is seen through the window and one for the very bright sunlight on the floor, and composite them together later.

The bottom line here is that the artistic intent, or subjective way to understand an image, might not match the values of the sene itself, those of the HDR images, or they might not fit within the limits of what can be displayed on the screen. So you will have to resort to interpretations, adjustments and tricks to reach your goal. There is no magic button to make things look "realistic", it is a highly subjective concept.

| improve this answer | |
$\endgroup$
  • 1
    $\begingroup$ This answer is so well written :). Thanks for all the effort you put into it. $\endgroup$ – Jachym Michal Apr 20 at 9:25
1
$\begingroup$

The problem is due to your colorspace most likely.

The human eye has the best dynamic range (which is how much contrast you can see in very light or very dark areas) of about 20 or so. This means that very light areas will be severely impacted as you will very soon see.

Technology is poor at simulating human vision. Your best iPhone camera has a DR of maybe 10 at best. sRGB (which is most likely the colorspace used here) has a DR of 5 or less. But Filmic has a DR of 25-30 and beyond

sRGB is also outdated; it was invented in the 80s and 90s for CRT screens and is likely being used by you now; unless you're on macOS or iOS.

You should really change your colorspace to Filmic...

As to why?

Because Filmic has such a high DR you can see a lot of contrast in bright and dark areas, just like your eye can. And that is realism in a nutshell.

  1. In the side menu, select the Render Settings tab-- it's on top, and goto Color Management -> Colorspace.
  2. Select Filmic, Filmic Log, or Filmic Log Encoding Base (in order of preference).
  3. If it is already selected, your sun lamp is way too strong... First reduce the sun lamp's strength to about 10-20 Watts. You may say "But my room looks dark!" I'd increase the exposure to compensate for that. (You may also want to change the gamma a bit.)

That should work. If it doesn't, try watching https://www.youtube.com/watch?v=m9AT7H4GGrA

| improve this answer | |
$\endgroup$
  • 1
    $\begingroup$ Would be a better answer if you explain why using filmic and not just posting this random tutorial IMHO. Related: Render with a wider dynamic range in cycles to produce photorealistic looking images $\endgroup$ – brockmann Apr 24 at 6:16
  • $\begingroup$ Filmic doesn't have a dynamic range of 25 stops or beyond. Where did you get such information? It is roughly ten stops below middle grey and six and a half stops over middle grey. $\endgroup$ – susu Apr 30 at 21:53
  • $\begingroup$ @susu I got my information from the video posted above. $\endgroup$ – PlanMan1717 May 2 at 1:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.