0
$\begingroup$

I have an image texture with black color. After i unwrap the object with smart UV, I have painted the entire object with colors. While i render, there are some part that have black stripes, and i assume it should be the color of the image texture. But if i have painted the entire object, how come there are still some part that is not being painted so it shows the color of the image texture?

enter image description here enter image description here

Totally beginner here and Thank You so much.

This is the blend file i am using.

$\endgroup$
  • 2
    $\begingroup$ Hi, hard to tell just like that, can you provide screenshots or the file? $\endgroup$ – Fowl Apr 20 at 6:27
  • $\begingroup$ Can you check to see that the whole object is assigned the material that carries the texture image? $\endgroup$ – Craig D Jones Apr 20 at 12:30
  • $\begingroup$ Hi, Thanks for replying. I not sure about how to upload a file or screenshot in here, so i could only upload the screenshots at Imgur. Below are the screenshots on the object at render and the image texture of it. imgur.com/a/UwoYVtd imgur.com/a/N3tAno3 Thank You so much for helping. $\endgroup$ – Che Xuian Apr 21 at 1:28
  • 1
    $\begingroup$ Hello :). You can share your .blend through Blend-Exchange. And add images directly using the image icon. It's much easier to solve problems with a shared file. $\endgroup$ – Jachym Michal Apr 22 at 12:09
  • $\begingroup$ @JachymMichal Hi :D Thanks for the great tips and it really help the beginner like me :) I have added the blend file at the post, could you kindly have a look at it if possible? Thank You so much. $\endgroup$ – Che Xuian Apr 22 at 13:30
1
$\begingroup$

Look in your tool settings under Properties for the Options panel, and set your bleed higher than 0, preferably 2 or maybe 4 pixels so that it will go 'outside' the uv mapped mesh, filling in the visible seams left by not enough overlap. enter image description here

Here is your file with the subdivision turned on, and then a full strength dab applied across the black area. enter image description here

| improve this answer | |
$\endgroup$
  • $\begingroup$ Thanks for helping, i tried but the same problem still exist. May i know what problem might cause this happening? $\endgroup$ – Che Xuian Apr 22 at 5:59
  • $\begingroup$ No, I see the black markings at teh edge of your islands in the 3d view and assumed that was because of bleed into margin - can you circle the area you mean to cover and also include screen shots of your settings? Also, can you append your object to a new file and see if the problem still occurs there? $\endgroup$ – Craig D Jones Apr 22 at 13:20
  • $\begingroup$ Hi, thanks for replying. The area i wish to cover is the black stripes that show at render. I tried to copy it to new file but the same problem exist. I just figure out how to attach my blend file to the post and i did it just now, can you kindly check it out if possible? Thank You so much :D $\endgroup$ – Che Xuian Apr 22 at 13:32
  • 1
    $\begingroup$ Oh i see! Thanks for helping, it solves the problem now :D $\endgroup$ – Che Xuian Apr 24 at 8:51
  • 1
    $\begingroup$ On the sculpt, when I zoom in the problem goes away - this could be because of the mesh being high density triangles and not a uniform mesh made of quads. Possible that it could be easier if you retopologize and then paint. $\endgroup$ – Craig D Jones Apr 24 at 20:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.