1
$\begingroup$

i have tried deleting the movie clip nodeSo i motion tracked a footage setup a scene did compositing and stuff so now i want only the 3d stuff without the video as a background. so i turned off the video, even tried turning off compositing in post processing, transperency is on in cycles,... but no matter what i do the renderer would render an image with transparency but when i save it as a png the background comes black. i have been banging my head for the past hour and just cannot fix this.

I beleive its because its rendering the foreground and then the background... i cant get it to render only one layer like it normally does on a new blender file. Even tried deleting the background layer and asking it to render a single layer.This is the renderer view this is the final png image which dosent save with he transparency

$\endgroup$
  • $\begingroup$ Could you add a screenshot of your Compositing node setup? $\endgroup$ – Bruno Apr 19 at 8:36
  • $\begingroup$ there added it.. got added to the top tho... $\endgroup$ – Riddhiman Panti Apr 19 at 8:51
  • $\begingroup$ Make sure to use RGBA (A as in Alpha) for your PNG output: i.stack.imgur.com/C4Cy4.png $\endgroup$ – Bruno Apr 19 at 8:54
  • $\begingroup$ i could kiss you right now it worked.... I always keep it in RGBAA.. even blender default is RGBA.. i have no idea how it got changed to rgb.... thanks a lot .. my head hurts from all the imagining myself banging my head on teh keyboard. $\endgroup$ – Riddhiman Panti Apr 19 at 9:20
2
$\begingroup$

Make sure to use RGBA (A as in Alpha) for your PNG output

enter image description here

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.