0
$\begingroup$

Thanks in advance. Missing some shadows cast by a spot outside a window in the render. Shows in the viewport but missing in the render. 2.82. Have tried a lot of things. Please help! Thanks! UPDATED: https://www.dropbox.com/s/1b4tkrldl1tufdx/Bosco_Prison_Cell_CHECKING.blend?dl=0 screenshot

$\endgroup$
2
  • $\begingroup$ The guy stands on the toilet and everything dark on every camera, maybe you uploded an incorrect file. $\endgroup$
    – FFeller
    Commented Apr 20, 2020 at 17:28
  • $\begingroup$ @FFeller hmmm. Just made another copy of the file with current position and updated post. LMK if this works.. I appreciate your response! $\endgroup$ Commented Apr 20, 2020 at 21:02

1 Answer 1

4
$\begingroup$

I found the problem with the sun's clipping, this might help you and others who have the same issue.

what I did:

  • Check scale
  • Check sun's shadow distance.
  • Look out for troublesome geometries this might have overscaled objects, micro objects, particles systems, hair, emitters, empty meshes, etcetera. normally you import objects from other softwares, in my case as an example I was using trees from forest pack, entities were there but empty, that caused my issue, I deleted them and it fixed the problem.

I hope this works.

now here is your problem: your scene you have this huge mesh outside the room :)

also you had a hidden geometry (the door's window), you have to delete it or desable it on render.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .