0
$\begingroup$

I've been trying to create rigify rig, by using the sample types. For example the sample the spines.super_spine.

Now I found out that we can adjust the amount of segments. (in the manual, https://archive.blender.org/wiki/index.php/Extensions:2.6/Py/Scripts/Rigging/Rigify/#Advanced_Usage)

When in pose mode, in the bone tab, I went over to rigify type. But whenever I change one of the settings, the spine chain doesn't update or I'm missing a step. This is what i'm doing:

enter image description here

Can someone explain to me what I'm doing wrong or better how to properly adjust the spine, and still keep the metarig fully functioning?

$\endgroup$
0
$\begingroup$

The final rig is created when you press Generate Rig (in Armature tab). Changing the options has no obvious effect until you generate the rig. Also I am not sure which version of blender you're using but it seems like you're using the legacy super spine. There is a newer one that separates head/spine/tail in different rig types.

$\endgroup$
3
  • $\begingroup$ Generating the mesh is the first thing I tried. But that didn't work. I double checked and I'm not using rigify in legacy mode. I'm using blender 2.80, do you use a newer versie of blender, rigify comes with blender now right? $\endgroup$ – MV.ARTZ Apr 19 '20 at 6:41
  • $\begingroup$ Try getting the newest version of Blender (2.82a as I write this). But I looked at your gif carefully. These settings are not supposed to update the bones themselves. They just define where the neck starts and where the tails starts. If you want more or less bones in the spine chain you have to add some manually (just extrude them). But definitely look at the updated spine. I find it easier to work with. $\endgroup$ – CGDive Apr 19 '20 at 10:40
  • 1
    $\begingroup$ Thanks, that clears somethings up. I was postponing the update, cause I'm in the middle of a few projects. But soon enough I'll update. Thank you again. $\endgroup$ – MV.ARTZ Apr 20 '20 at 11:31
0
$\begingroup$

iv' been losing my mind orver this, the supper spine don't have enough bones to perform proper deformation on the mesh, mostly between chest and hip/neck, and also lack a proper configuration panel. i ''solved'' by simply dividing the bone which were too stiff. Riggify auto adds a control to it when generated and didn't seamed to cause any problem so far. hope this helps.

$\endgroup$
1
  • $\begingroup$ Yeah that could work. Thanks ! $\endgroup$ – MV.ARTZ Jul 27 '20 at 14:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.