0
$\begingroup$

I'm having this problem for quite some time with all of my projects. When I'm trying to render an image or animation (I'm rendering with GPU only because it's the fastest way for me), the beginning gets rendered really quickly, but after a short time later (when the render is finished at 15%), the process becomes really slow, until the end. I have posted details about my machine and the reference photo too below:

My specifications:

  • Processor - Intel(R) Core(TM) i7-9750H CPU @ 2.60GHz 260GHz;
  • RAM - 8.00 GB (during rendering, it only uses ~500 MB);
  • The program is installed on SSD disc;
  • Windows 10 Home 64 bit (version 1809);
  • GPU - NVIDIA GeForce GTX 1650 6 GB.

My render image: enter image description here

As you can see, very little of the GPU is used, which is why I think the rendering is slow...

$\endgroup$
  • $\begingroup$ can you share the screen of your system configuration inside blender? (also try to enable only GPU inside blender, this could help) $\endgroup$ – Sanbaldo Apr 14 at 11:17
  • $\begingroup$ @sanbaldo What do you mean by inside Blender system configurations? How and what should I show specifically? And yeah, I have the GPU Compute setting on in Blender if that's what you had in mind. $\endgroup$ – lucutes Apr 14 at 11:20
1
$\begingroup$

Go to system settings (Blender top menu > Edit > Preferences > System) and check that you are using CUDA with GPU checked and CPU un-checked

enter image description here

Check also that you are using GPU on the "Render properties":

enter image description here

| improve this answer | |
$\endgroup$
  • $\begingroup$ Yup, my settings are just the same as yours. I've also played with tile sizes, still no luck. $\endgroup$ – lucutes Apr 14 at 11:37
1
$\begingroup$

I think blender uses CPU to calculate the "Math" such as calculating the location of vertices of a mesh while moving and deforming. I think Subdivision Surface Modifier uses a lot of CPU as it adds more vertices to the mesh.

GPU is used to calculate lighting and materials.

If you have too much animation in your scene and you don't have a powerful CPU, the GPU will be bottle necked. For each frame, the CPU will work very hard to calculate the locations of the vertices, particle systems, ...etc. Then, the GPU will calculate the shadows, light bounces, materials, and textures. As a result, you will see that you use the CPU more than the GPU in the rendering process.

I figured out this answer by experimenting only. This my own personal interpretation of this behavior based on observing. There could be a better answer with the solution but that's what I know so far.

| improve this answer | |
$\endgroup$
  • $\begingroup$ Not even a single subdivision modifier was used in this project, and the other project where I had quite a lot of subdivisions applied, bizarrely, the render times for both are at the same speed. This is some creepy magic going on, since for both of those projects, which are different in their own way, the rendering speed is just the same!? By the way, the only animation I did for this scene is just camera movement, flying around and then zooming in like motion, total 25 frames, shouldn't be too complicated for my laptop... $\endgroup$ – lucutes Apr 14 at 13:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.