1
$\begingroup$

I'm editing a bunch of 3d scenes in the sequencer right now and naturally they won't play back in real time. Is there a way to cache the render?

Thank you!

$\endgroup$
4
  • $\begingroup$ Just to make sure I understand you correctly. You have several 3D scenes that can't be rendered smoothly in the 3D viewport with the playback frame rate? And these scenes are also not rendered with the playback frame rate in VSE? $\endgroup$
    – J.Doe
    Commented Apr 13, 2020 at 11:29
  • $\begingroup$ Which Renderer does the scene use you want to View? And what is your scene "Preview Shading" in the Sequencer? $\endgroup$
    – J.Doe
    Commented Apr 13, 2020 at 12:41
  • $\begingroup$ Hey J, thanks for your answer. I use Eevee and yes the scenes stutter when playing back. Is there a way to "Render the timeline" just like in a regular editing software? Obviously not a final render, but just to have smooth playback from the sequencer timeline. Thanks! $\endgroup$ Commented Apr 13, 2020 at 13:12
  • $\begingroup$ I just setup a simple scene in Blender 2.82.7 and addet it in a new scene to the VSE. After one playback Blender seems to automaticly cache Frames ant the playback is realtime. $\endgroup$
    – J.Doe
    Commented Apr 13, 2020 at 13:28

1 Answer 1

0
$\begingroup$

I just setup a simple scene in Blender 2.82.7 and addet it in a new scene to the VSE. After one playback Blender seems to automaticly cache Frames ant the playback is realtime. Blender Docks

Ther is an option to prefetch frames .. but this semse to be brocken as of right now (2.82.7) https://developer.blender.org/T70612

Nevertheless caching seems to work.

Create animation enter image description here

Create new Scene.001 and add the Scene with animated cube to Sequencer. enter image description here

Start Playback and wait for all frames to get rendered once. Blender will skip Frames trying to keep realtime playback up as best as possible, but eventualy all frames will be cached. (probably untill no more frames fit into RAM) enter image description here

Otherwise the goto way to work in the VSE is to render out your animation scenes in image Sequences and compose them in the VSE afterwards to render your final encodet video file. This way you have them on disk no matter wat happens and can rerender frames you need to change.

For indepth information see Video Editing Workflow: Use a separate scene for VSE? and Movie editing : VSE or compositor?

$\endgroup$
4
  • $\begingroup$ Thanks for your detailed answer! So the solution for me is to let the video play in a loop until all the frames are rendered. It's a bit weird that there's no button for that, but it works! Thanks! $\endgroup$ Commented Apr 13, 2020 at 15:55
  • $\begingroup$ Thank you for not reading it properly ^^. Ther is a button for that! But if you press it Blender will crash as of right now. Much easyer option is to not set your viewport to renderd but to Solid. Even better render your animation independent from the cutting process as descruibed in the Answers i Linked ;) That way you dont lose your render everytime you close Blender. $\endgroup$
    – J.Doe
    Commented Apr 13, 2020 at 17:10
  • 1
    $\begingroup$ I know there is a button (it's in the viewport sidebar, foer anyone looking for it), but as you already found out it's a bit buggy. Also...yes, if you render out your movies you can then edit them...in Blender or anywhere, but that's not what I was looking for. Thanks anyway, you pointed me to the right solution in your first answer. $\endgroup$ Commented Apr 13, 2020 at 19:38
  • 1
    $\begingroup$ Not sure if you're still using this workaround but - if you set playback to "Play Every Frame" at least you can do this in a single pass rather than having to wait for several loops. $\endgroup$
    – ddd
    Commented Oct 12, 2023 at 14:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .