0
$\begingroup$

I have created an object and drew the texture on it, it worked and still works fine. Then I created another island, created and assigned another texture to it. However, Texture Paint mode doesn't work for it! I can draw only on the left side, on the texture itself, but not on the object... How can I solve it?

screenshot

$\endgroup$
0
$\begingroup$

before you do anything check your blend mode in 3d view by pressing n > Tool > brush setting > blend mode and set it to mix

enter image description here

1) check if object is selected first

2) isolate object before painting by pressing num/ or ~ to toggle local view

3) make the clip start smaller. (3d view > press N for right panel to show up and view > clip start) enter image description here

4) try saving your image before doing the actual painting then save blender file then go File > Revert and see if the issue still exist. 5) if all else fails just go to edit mode and press ctrl+shift+n to recalculate normals and try again painting it.

$\endgroup$
3
  • $\begingroup$ 0. The mix mode was on, you can see it on the screenshot. Also, the other object gets painted well while brush settings are the same, thus it's perhaps not a problem. 1. Of course I've selected the correct object. 2. Object isolation did nothing helpful. 3. Current clip settings work fine for other object... 4. I've re-opened projects many times. Tried reverting (what's it?), nothing changed. 5. Hooray! Indeed, I had flipped normals (the object is plane), didn't know it's a problem... $\endgroup$ – AivanF. Apr 12 '20 at 17:52
  • $\begingroup$ I also have another, small issue: when I select an object, the selected texture doesn't get changed to the object's one, I have to pick manually (e.g "Terra Island" texture in the right menu of my screen). Do you know, is it possible to make some link between object and the texture so it will be selected automatically when I select an object? $\endgroup$ – AivanF. Apr 12 '20 at 17:55
  • $\begingroup$ as far as I remember it will show you the last selected texture in shader menu. $\endgroup$ – Mobin Apr 12 '20 at 18:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.