1
$\begingroup$

If there is multiple vertexes with the same coordintates (i.e. on top of each other) in a mesh, the select box tool selects just one of them and ignores the rest.

  • Is this a feature or a bug?
  • Can it be switched/modified in order to really select all vertexes within the box even when they overlap

background:

I have some mesh exported from external editor where triangles (faces) are disconnected => each triangle has its own corner vertex => if you have e.g. 5 triangles meeting at one corner, you have 5 independent vertexes at that corner

In order to edit such a mesh I need to select all these vertexes and move them simultanously.

$\endgroup$
2
$\begingroup$

Toggle X-Ray

In the 3D view header, check Toggle X-Ray (or press Alt+Z). You can now select the vertices sharing the same coordinates, but also the "backfacing" vertices (those hidden by the mesh).

Merge vertices

If you really want to merge those vertices (so your 5 independent vertices become one unique vertex), you can use the Merge by Distance feature.

Select all your vertices (A), then go to Vertex/Merge vertices/By Distance (or press Alt+M). In the Last Operator menu, you can specify the distance under which the vertices will be merged.

| improve this answer | |
$\endgroup$
  • $\begingroup$ Aha, thanks, I notice sometimes it works and sometimes not, but I did not realized it depends on "X-Ray" option $\endgroup$ – Prokop Hapala Apr 12 at 12:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.