I've spent a few hours on google/stack exchange/reddit and somehow can't figure out how to get my mantaflow sim to show up in my final render.

I've baked the data and mesh, set the sim to replay, and everything is set as visible to renderer. When I play the simulation in the viewport renderer it works fine and looks great. But when I try to render and output the image or animation it only shows the fluid emitter - the actual simulation just doesn't appear. When I apply the fluid sim in the modifier stack it appears in the final render, but it just bakes the mesh where it's at with no animation.

I've tried moving my cache to a different folder, starting over with a new simulation, and even tested it on my laptop. I just can't get the fluid to show up. Any help would be appreciated - I'm sure it's a stupid easy fix, but I've spent a few hours on it and just can't figure it out.

Here's the blend file for reference: https://pasteall.org/blend/4a093bb431944141bbda50ed875f1f38


  • $\begingroup$ Did you enable mesh in the domain settings and bake it too? $\endgroup$ Commented Dec 29, 2021 at 0:39

1 Answer 1


This rendered for me, see attached zip file. Only changes l made:

  • changed cycles from experimental
  • rendered a frame past frame 141 - increased the animation frames to 250 as it seemed at 75, 141 much wasnt coming out of the effector mesh holes , thus increasing the simulation .
  • increased the point light strength.
  • changed the fluid material to Glass [ie water look]

File: https://drive.google.com/file/d/1vuo8yEqGqUA4-DrVcNGuQoPjvgYsHEjg/view?usp=sharing


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .