1
$\begingroup$

According to this question: Why OBJ export writes face normals instead of vertex normals

Whether the final obj uses vertex normals or face normals depends on the choice of shading.

However I always get the face normals.

enter image description here

I am switching between the 2 to see if there's a difference but there's none. These are my normals:

vn 0.0000 1.0000 0.0000
vn 0.0000 -0.0000 1.0000
vn -1.0000 -0.0000 0.0000
vn 0.0000 -1.0000 -0.0000
vn 1.0000 -0.0000 0.0000
vn 0.0000 0.0000 -1.0000
$\endgroup$
2
$\begingroup$

If you're just switching between Shade Flat and Shade Smooth you should see a difference in the viewport and in the exported .obj file. If you have Auto-Smooth enabled, then this will influence the normals and could make the result identical to Shade Flat if the Auto-Smooth Angle is lower than the 90° angles in the cube.

Shade Flat

# Blender v2.81 (sub 16) OBJ File: ''
# www.blender.org
o Cube
v 1.000000 1.000000 -1.000000
v 1.000000 -1.000000 -1.000000
v 1.000000 1.000000 1.000000
v 1.000000 -1.000000 1.000000
v -1.000000 1.000000 -1.000000
v -1.000000 -1.000000 -1.000000
v -1.000000 1.000000 1.000000
v -1.000000 -1.000000 1.000000
vt 0.625000 0.500000
vt 0.875000 0.500000
vt 0.875000 0.750000
vt 0.625000 0.750000
vt 0.375000 0.750000
vt 0.625000 1.000000
vt 0.375000 1.000000
vt 0.375000 0.000000
vt 0.625000 0.000000
vt 0.625000 0.250000
vt 0.375000 0.250000
vt 0.125000 0.500000
vt 0.375000 0.500000
vt 0.125000 0.750000
vn 0.0000 1.0000 0.0000
vn 0.0000 0.0000 1.0000
vn -1.0000 0.0000 0.0000
vn 0.0000 -1.0000 0.0000
vn 1.0000 0.0000 0.0000
vn 0.0000 0.0000 -1.0000
s off
f 1/1/1 5/2/1 7/3/1 3/4/1
f 4/5/2 3/4/2 7/6/2 8/7/2
f 8/8/3 7/9/3 5/10/3 6/11/3
f 6/12/4 2/13/4 4/5/4 8/14/4
f 2/13/5 1/1/5 3/4/5 4/5/5
f 6/11/6 5/10/6 1/1/6 2/13/6

Shade Smooth

# Blender v2.81 (sub 16) OBJ File: ''
# www.blender.org
o Cube
v 1.000000 1.000000 -1.000000
v 1.000000 -1.000000 -1.000000
v 1.000000 1.000000 1.000000
v 1.000000 -1.000000 1.000000
v -1.000000 1.000000 -1.000000
v -1.000000 -1.000000 -1.000000
v -1.000000 1.000000 1.000000
v -1.000000 -1.000000 1.000000
vt 0.625000 0.500000
vt 0.875000 0.500000
vt 0.875000 0.750000
vt 0.625000 0.750000
vt 0.375000 0.750000
vt 0.625000 1.000000
vt 0.375000 1.000000
vt 0.375000 0.000000
vt 0.625000 0.000000
vt 0.625000 0.250000
vt 0.375000 0.250000
vt 0.125000 0.500000
vt 0.375000 0.500000
vt 0.125000 0.750000
vn 0.5773 0.5773 -0.5773
vn -0.5773 0.5773 -0.5773
vn -0.5773 0.5773 0.5773
vn 0.5773 0.5773 0.5773
vn 0.5773 -0.5773 0.5773
vn -0.5773 -0.5773 0.5773
vn -0.5773 -0.5773 -0.5773
vn 0.5773 -0.5773 -0.5773
s 1
f 1/1/1 5/2/2 7/3/3 3/4/4
f 4/5/5 3/4/4 7/6/3 8/7/6
f 8/8/6 7/9/3 5/10/2 6/11/7
f 6/12/7 2/13/8 4/5/5 8/14/6
f 2/13/8 1/1/1 3/4/4 4/5/5
f 6/11/7 5/10/2 1/1/1 2/13/8
$\endgroup$
  • $\begingroup$ I have no explicitely enabled auto smoothing, where can i check if it is enabled? $\endgroup$ – Makogan Apr 9 '20 at 20:51
  • $\begingroup$ @Makogan Object Data Properties > Normals > Auto-Smooth (The green triangle face icon in the property tabs). $\endgroup$ – Robert Gützkow Apr 9 '20 at 21:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.