1
$\begingroup$

I a complete beginner in Belnder. (I use 2.8 version of it). I used to work with cinema 4d years ago, so I have the idea about some basics of working with 3D. But as I see Blender is a lot more complicated and complex.

I found this model online and made used a Decimate modifier to reduce the size. Now I need to colorize it but for some reason I face this issue:

After unfolding UV and painting the model it paints the inside part of it.

The example of blender model texture paint

This happens when I zoom inside the model and paint it from the iside:

enter image description here

UPD.1 I figured out it has to do with Normals facing different directions, I recalculated them outside, it seemed to help a little but still it very edgy. There are some lines between the polygons and some of normals keep facing the wrong direction.

$\endgroup$
2
$\begingroup$

I believe some of your face normals are flipped OR you have overlapping faces / really rough topology, OR you need to unwrap your model more cleanly without UV distortion and maybe even increase the UV texture resolution.

To fix normals: Tab for Edit Mode, then A to select all. Ctrl+Shift+N to recalculate normals (untick "inside").

Fix overlapping geometry: a quick fix might be Re-Mesh modifier. Be sure to save an alternate version before flattening ("applying") a modifier because it is destructive.

UV Unwrap quick fix: Edit Mode, select all faces, U "Lightmap Pack" or "Smart UV Project". Make sure your UV image texture is a large enough resolution and that your UV islands have enough margins between to prevent overlap.

| improve this answer | |
$\endgroup$
  • $\begingroup$ Thank you so much for the answer, I've tried to fix normal, but unfortunately many of them keep facing wrong direction. What about Re-Mesh, I need to keep it low poly and recognisable, after re-mesh it really looses the shape. $\endgroup$ – Aleksandr Moroz Apr 8 at 23:32
  • $\begingroup$ Have you tried to Set Origin>Origin to Geometry in Object mode? Do that, and THEN recalculate normals. See if that helps. Also, try Ctrl+A to apply Scale, Location, and Rotation. Then try recalculating normals. $\endgroup$ – Coby Randal Apr 8 at 23:48
  • $\begingroup$ Maybe try backface cull, view from inside the mesh, select only facing faces and recalculate those alone and flip them outwards? $\endgroup$ – Coby Randal Apr 9 at 14:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.