0
$\begingroup$

In edit mode, with the bones set to wireframe view, I'm simply trying to select one bone, and then shift select another bone, in order to parent one to the other.

The issue, is that the target bone is inside/behind another. and I cant seem to select through it? Each time I go to shift select in inner bone, it selects the larger outer bone.

I believe this should be possible in wireframe mode by selecting the bone outline? But it doesn't seem to be the case?

I can work around it using the outlier, but the issue of selecting bones inside/behind other bones is something I'm looking to solve.

enter image description here

$\endgroup$
1
$\begingroup$

A bone inside like that is more difficult to select but you can do it two other ways that I know of:

  1. Double click on it. Be fast! Mouse cursor right on it, and it works.
  2. Select larger bone, Shift+G "Direction", "child" ect and it may also help in certain situations, especially when dealing with multiple parent bones and children.
| improve this answer | |
$\endgroup$
  • $\begingroup$ Hey. Thanks for those tricks. Though, if i shift double click the bone, it adds both the outer and inner bone to my selection, leaving the smaller bone as the active object. This would then lead to both the top and outer bone being parented to the inner bone. Instead of just the top bone. I'm new to rigging in blender, but I've been rigging in general for a while. It's is a common technique to have bones laid out like this. This was definitely possible in other versions of blender. Can see here: link $\endgroup$ – FunkyRabb1t Apr 10 at 12:46
  • $\begingroup$ I've just noticed this only seems to affect orthographic view / edit mode. Can select the inner bone through the larger bone ok in perspective view in pose mode... Perhaps a bug? $\endgroup$ – FunkyRabb1t Apr 10 at 15:48
  • $\begingroup$ Good question. Man I see from the gif it looks so easy and nearly effortless to select the bone inside. It also appears that they were in wire frame view ("Z" key. Shading>Wireframe). Goes and tries in 2.82a Yup. It's easier in wire frame mode! How do you like it? $\endgroup$ – Coby Randal Apr 10 at 16:42
0
$\begingroup$

I had the same problem as you and I've just found a way to make it work.

On the Blender Preferences, under the Viewport tab you'll find a selection dropdown. If you uncheck the OpenGL Depth Picking option it should work as you expected.

enter image description here

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.