1
$\begingroup$

After rendering my scene in cycles with a transparent background, I saved the image as a PNG with alpha with 0 compression. I thought everything was fine until I examined it very closely. Certain parts, mostly the darker areas, appear to be about 5-10% transparent, barely noticeable. They SHOULD be 100% opaque. The only thing that tipped me off is that I have my Photoshop transparency set to a Pink/white checkerboard. Some areas I can barely make out the checkerboard underneath.

I've checked the materials, and there is no transparency set, no alpha mask/layer, nothing. Other areas of the same object seem fine, although maybe I just cant see it in the brighter areas. It also happens on other objects in the scene with different materials.

I can workaround by duplicating the layer in photoshop, but I'm really curious If anyone seen something similar, and what could be causing it.

Here are links to the blend file(s), I don't know why there are 2 but I included both.

http://www.mediafire.com/file/1xlinwk8xok1sif/stackexchange.blend/file http://www.mediafire.com/file/ghc2f5zhdp8672w/stackexchange.blend1/file

enter image description here

$\endgroup$
  • $\begingroup$ Can you upload the blend file please? Are you using 2.82a? What do you mean your background is transparent? You have set Cycles Render Settings>Film>Transparent? But everything should be opaque? If I wanted everything opaque, I would turn off Transparent and I would save PNG without alpha. I would like to know more about your situation so we can solve it. Thanks. $\endgroup$ – Coby Randal Apr 8 '20 at 22:29
  • $\begingroup$ Yes, I have set Cycles Render Settings>Film>Transparent. Sorry, that's what I meant by transparent background. Trying to figure out how to upload the blend file. $\endgroup$ – user87368 Apr 9 '20 at 20:58
  • $\begingroup$ Was not using 2.82a, I'll try the update. $\endgroup$ – user87368 Apr 9 '20 at 21:22
0
$\begingroup$

After having a look at your file (without textures attached) I have several suspicions:

  • "Noah's place bighter 2.exr" may have alpha issues
  • World background nodes> "Background" node itself was set to 0.920 instead of 1.
  • Compositor nodes> "Composite" node was set to "Use Alpha". Disable that?
  • Render settings>Film>Transparent>"Transparent Glass" was on. Turn off if you don't need it.
  • Render settings>Film>"Transparent" was on. Turn off if you don't it.

You can also check the alpha of your render directly in blender "render" window by right clicking the final render image and holding the mouse cursor over image pixels in question. It reads out RGB and alpha values.

$\endgroup$
  • $\begingroup$ Thanks man, I'll try those. The background node being set to .92 is supposed to only affect how much light the background contributes, but it is suspiciously close to the amount of opaqueness that I see in areas. $\endgroup$ – user87368 Apr 9 '20 at 22:31
  • $\begingroup$ I have tried every single thing with no effect. I have tried different HDRIs from a known good source(HDRI Haven), Disconnected the world output node, Even deleted all composite nodes and turned film transparency off at the same time.. The output is still semi-transparent in photoshop(latest). Older versions of the same file DO NOT have this issue. Not sure what the difference is. None of my textures have an alpha layer and are in jpg format. $\endgroup$ – user87368 Apr 10 '20 at 22:39
  • $\begingroup$ Have you tried saving as .png RBG (no alpha)? Tried .exr or .tga? Can you right click the Blender render window and check the alpha values? I think Photoshop might be misusing that .png with alpha. If you don't need alpha, why save as .png with alpha? $\endgroup$ – Coby Randal Apr 10 '20 at 23:34
  • 1
    $\begingroup$ Thanks, you got me pointed in the right direction. It has to have alpha since it is to composited over another background in PS btw. Right clicking in the render window told me that that alpha was 1.0 everywhere. So, it was not a blender issue. What I ended up finding was that if I saved in PNG 16 bit, the alpha issue was apparent in PS. If I saved in 8 bit, everything was back to normal. No idea why. $\endgroup$ – user87368 Apr 11 '20 at 17:46
  • $\begingroup$ Wow that is interesting. Glad you found that! Be advised that .png is not necessarily the best for compositing. There are plenty of in-depth forum and stackexchange posts that will show why high bit depth .EXR files are generally better suited for composites. But if it works for you, it works! Be aware that .png will only get you so far before other issues occur. $\endgroup$ – Coby Randal Apr 12 '20 at 6:19
0
$\begingroup$

The fix ended up being to save the render as an 8 bit PNG file rather than a 16 bit. Somehow the 16 bit save results in strange alpha issues in Photoshop. Thanks Coby for the help.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.