This is a newbie question but I've searched all over and can't find a solution.

I'm following this tutorial to create procedural clouds and it works perfectly https://www.youtube.com/watch?v=GhMQN4vVMIU

But I'd like to add these clouds to a small scene, which has been created using BlenderGIS and then scaled right down. I've scaled it down so that camera depth of field can give the scene a 'model village' type of look. At full size, depth of field has no effect because the scale is massive.

When I scale the clouds down, they become almost completely transparent, seemingly no matter how high I set density.

This image is a copy from the YouTube link showing the shader (the missing bits to the left are texture coordinate and random noise).

enter image description here

It's the principled volume step that causes the cloud to go almost completely transparent when small. Without that it works, but the cloud doesn't have a nice density effect.

Is there a way to make a cloud like this very small and maintain the density? I found references to 'Density Scale' in the user manual prior to 2.8 but not sure if that's what I want and I can't find references to it anywhere in 2.8.


  • $\begingroup$ Hello :). Don't forget to bump up sample count in Render > Volumetrics. They're set pretty low by default. $\endgroup$ – Jachym Michal Apr 8 at 15:22
  • 1
    $\begingroup$ That seems to have cracked it, thanks. I couldn't find a setting anywhere that made a difference! $\endgroup$ – NeilC Apr 8 at 15:54

Don't forget to bump up the sample count in Render > Volumetrics > Samples.
They're set pretty low by default.

enter image description here

| improve this answer | |
  • 1
    $\begingroup$ For anyone else stuck on the same problem, Jachym's tip helped but I also needed to change 'End' in volumetrics to a much smaller number to finally deal with the issue. $\endgroup$ – NeilC Apr 9 at 17:30
  • $\begingroup$ Thanks for letting me know :). I don't work much with Eevee, so any feedback is appreciated. $\endgroup$ – Jachym Michal Apr 9 at 17:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.