0
$\begingroup$

I'm trying to eliminate the "bouncing" or flickering reflection of an animated object rendered using EEVEE. I have a simple text object on a semi-reflective surface (specular 1.0, roughness 0.25) and screen space reflections enabled. When the camera is motionless, the reflection appears fine, but once the camera begins to move even slightly, the reflections begin to bounce and jitter as seen in the clip below. I'm somewhat (erroneously?) confident this is something to do with EEVEE's screen space reflections. The bouncing disappears when I render in cycles.

Flickering from Screen Space Reflections

So, what exactly is happening here? I have played with each screen space reflection setting, but none seem to eliminate the flicker. The Blender manual mentions using a reflection plane, but also mentions that you lose the effects of subsurface scattering, volumetrics, and screen space reflection/refraction, which is not desirable.

Maybe I've gone down the wrong rabbit hole, but other basic troubleshooting such as increasing samples doesn't have any effect. Of course, turning off screen space reflections eliminates the problem ...and the reflection, which isn't desired.

Any thoughts?

$\endgroup$
1
$\begingroup$

This is why you should use EEVEE more as a low budget render, fast interaction before making the final render with Cycles.

EEVEE is real-time, therefore less quality. The flickering probably only gonna disappear if you turn off the screen space reflection and use raytraced reflections You can also use later Blender releases that improve SSRF.

I've been using rasterized screen space effects elsewhere and that flickering appears constantly, so I confidently say it's inherent to kind of SS effects, so it's probably impossible to remove it completely, only to minimize by bumping EEVEE render settings.

$\endgroup$
1
  • $\begingroup$ Thank you for the response! I appreciate the information. It's good to know it's not just me. :) $\endgroup$
    – H. A. Camp
    Sep 12 '20 at 15:26
0
$\begingroup$

I know this is an old thread but I just encountered and solved this issue myself. Turns out if you scale objects too large you run into floating point accuracy problems. So in my case the solution was to cut the reflective surface up from one large plane to an array of smaller ones and the issue was fixed.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.