1
$\begingroup$

I am coming back to use Blender after a bit of a break of a couple of years. I did a lot of work using version 2.7x. I am now trying to use version 2.82a.

My PC is running Linux Mint 19.3 I have 32GB RAM, 16 Core Ryzen Threadripper 1950X and 12GB GTX 1080Ti. I have the nvidia drivers installed and I am using CUDA.

What I find that for a modest sized model (approx 1M verts) version 2.79 is very responsive with zero lag. With 2.82a everything lags, not just zooming or moving the model but also menus and any selection can take seconds.This is in Solid viewport mode, so no textures or rendering.Render speeds are OK.

Are there any ideas as to how to fix this?

Thanks Baz

$\endgroup$
4
  • 1
    $\begingroup$ Do you using Viewport Anti-Aliasing (Preferences > Viewport > Quality) ? $\endgroup$ – RUben Apr 7 '20 at 12:26
  • $\begingroup$ Run blender from terminal and check output during workflow! It may be some lagging addon spoils life! Ether run blender --factory-startup $\endgroup$ – RUben Apr 7 '20 at 12:29
  • $\begingroup$ Thanks. In a sense what you suggested fixed it. The problem was quite simple - the desktop shortcut I was using used blender-softwaregl rather than blender. It looks like blender-softwaregl is the root cause. It also appears to cause some faces to not be displayed in solid or material, which was odd. $\endgroup$ – bazza2jw Apr 7 '20 at 14:47
  • $\begingroup$ If you used software-gl then this is no surprise. It emulates OpenGL in software instead of using your GPU for hardware acceleration. $\endgroup$ – Robert Gützkow Apr 7 '20 at 14:54
0
$\begingroup$

I had this same problem and I found a few ways to fix this. By default, the resolution % in 2.8 is set to 100%, whereas it was always 50% before. This only applies to renders however, not really anything else. You can find it in the Output tab underneath your dimension. Another thing you should do is make sure Blender is using your GPU. In your Render tab it may tell you it's using GPU compute but you need to go into your Preference settings and make sure it is using Cuda. I found all this out this morning and my render times went from 2 minutes to 12 seconds, and my playback is a lot smoother.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.