I have pretty standard mesh with a sub surface modifier (not applied).

Editing has been fine until now - now when I subdivide an edge (one cut) it creates a small black diamond around the new vertex. When I toggle 'Display in viewport' in the subsurf modifier the diamond disappears correspondingly so the two are related. I also can't recreate this in a fresh scene with just the default cube.

Blender version 2.82.7 - any ideas?

enter image description here


1 Answer 1


It seems that you subdivided, just this edge. The result is a n-gon which will cause problems with the subsurface modifier. It even looks like the resulting vertex is not connected to both faces, so the subsurface-modifier sees this vertex as a corner and rounds it. Go into vertex-editing and find the 5th vertex (it's exactly where this weird triangle is) and dissolve this single vertex, by deleting it and choose the dissolve vertex option. After that find out if the face over and below that edge are connected, the easiest way to find out is to just move the edge, if both faces follow you are good, if not you will have to merge the faces with on common edge between. I hope I could help you with that. All the best Marco

  • $\begingroup$ Thanks Marco you've helped to isolate the problem.This can be recreated with the default cube, add a subsurf, smooth shading, then subdivide any edge. Seems that a while n-gons are supported, a vertex connected to 2 n-gons at the same time causes a tear in the surface. $\endgroup$ Apr 6, 2020 at 3:12
  • $\begingroup$ Great, I'm glad I could help you. All the best Marco $\endgroup$ Apr 6, 2020 at 7:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .