2
$\begingroup$

Hi I am using Particle Properties - Hair to put slender particles inside a specific volume mesh (Emit from: Volume). But I find for some particles, they can go outside my volume. How can I confine particles within a volume? Thanks a lot!

enter image description here

$\endgroup$

2 Answers 2

1
$\begingroup$
  1. Duplicate your main volume in place
  2. Remove the particle system from the main volume
  3. Scale down the duplicate so that the particles fit into the main volume
  4. make sure to turn Show Emitter off in the Particle Settings panel

enter image description here

$\endgroup$
4
  • $\begingroup$ Thanks for the answering! Is there a feature that goes with the original volume to confine the particles? $\endgroup$
    – Jarvis Du
    Commented Apr 4, 2020 at 18:39
  • $\begingroup$ Not that I know of. I think the particle system is using the Origin of the particle object to determine its position within the volume. $\endgroup$
    – Bruno
    Commented Apr 4, 2020 at 19:13
  • $\begingroup$ OK! But this works pretty well though! Thanks a lot! $\endgroup$
    – Jarvis Du
    Commented Apr 6, 2020 at 16:43
  • $\begingroup$ Correct me if I'm wrong, but I can't get this to work as expected unless I add Collision to both volumes. $\endgroup$
    – Aubrey
    Commented 4 hours ago
0
$\begingroup$
  1. Add a solidify modifier on the emitter
  2. Place it above the particle system in the modifiers stack enter image description here
  3. Switch on 'Use Modifier Stack' under the particle system's Source options, if not already
  4. Turn up the solidify thickness value until the particles are filled in properly
$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .