1
$\begingroup$

I have added an edge bevel weight on my mesh, So I wouldn't have to add more geometry and keep the mesh as clean as possible. Once I add a MatCap material on it, the corners are visible of some unclean mesh which is visible. If I add loop cuts it will clean up the topology, but it would also distort the object. So I'd like to know how to eliminate the unclean corners without adding more geometry to the mesh.

enter image description here

$\endgroup$
0
$\begingroup$

There is also an option of using the bevel node. Manual

$\endgroup$
1
  • 1
    $\begingroup$ Hi Andrei, Thanks for the info, I'm aware of the Bevel node, and will be used in the future when I update my PC.. Because I'm currently using EEVEE render engine. Kind regards. $\endgroup$ – blender breath Apr 5 '20 at 7:37
3
$\begingroup$

There are three things that could improve the corners and shading.

  1. Change Outer Miter Type of bevel
  2. Check Harden Normals in Bevel Modifier
  3. Enable Autosmooth in Mesh tab

enter image description here

image description

$\endgroup$
2
  • $\begingroup$ Ok, thanks for the tip Jachym. Regards. $\endgroup$ – blender breath Apr 5 '20 at 7:41
  • $\begingroup$ Happy to help :). Please mark the anwer as accepted , if it solved your problem :). $\endgroup$ – Jachym Michal Apr 11 '20 at 18:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.