4
$\begingroup$

I have a bed of pebbles that have been physics simulated and are now in a resting position:

pebble bed

I want to append this to an architectural render I'm working on. When appending, the pebbles go back to their start position (suspended in space).

I don't want to bake the simulation, because it's only the ending position I care about. Is there a way to apply all the pebble's positions?

$\endgroup$

4 Answers 4

4
$\begingroup$
  1. Create you RigidBody simulation
  2. Choose the desire frame
  3. Select your objects,
  4. perform Bake to Keyframes (hit F3 for the search menu and type bake)
  5. Change the frame range to the frame selected. If you leave the default, i.e. multiple frames, it create keyframes for all.

ALTERNATIVE:

  1. step to the desired frame,
  2. Apply Visual Transform followed by
  3. either Remove Rigid Bodies or Remove Rigid Body World

enter image description here enter image description here

$\endgroup$
4
  • $\begingroup$ The menu item Bake to Keyframes does not appear when I search (prob because I had already baked, which doesn't work when linking across files). Nevertheless, you gave me the idea to try Remove Rigidbody World (at the desired keyframe), and it worked! If you edit your answer to explain how to get the menu item, or amend it to include my solution, I'll be glad to mark it as accepted. $\endgroup$ Apr 4, 2020 at 13:04
  • $\begingroup$ Roger that thank you $\endgroup$
    – Bruno
    Apr 4, 2020 at 13:13
  • 1
    $\begingroup$ That said, removing the RigidBody World did not work for me. Even after baking the cache. It simply reverts to the original position. $\endgroup$
    – Bruno
    Apr 4, 2020 at 13:22
  • $\begingroup$ After a few tests, I can confirm that stepping to the desired location and doing Apply Visual Transform followed by either Remove Rigid Bodies or Remove Rigid Body World will work. $\endgroup$ Apr 4, 2020 at 17:04
3
$\begingroup$

First off, go to the target frame and make sure only your pebbles are selected.

In the 3D Viewport, under Object > Rigid Body select Apply Transformation. This will make the current position the pebbles' starting one.

enter image description here

Then, in the same submenu, click Remove to remove the pebbles from the Rigid Body simulations; that is, to make them simple, static meshes again.

$\endgroup$
2
  • $\begingroup$ I did try this solution, but the frames are animated as before. Will this work with clones of objects (all my pebbles are three different copies that share the same mesh and material)? $\endgroup$ Apr 4, 2020 at 1:51
  • $\begingroup$ I'm conflicted, because when I tried your answer, the Remove option did not appear. However, in a new file, it does, and your solution works. So, you solution did not solve my problem, but it does work. However, because of everyone's input, I was able to find a way, so I'm marking this one as correct. $\endgroup$ Apr 4, 2020 at 17:07
1
$\begingroup$

Select the object and press CTRL + A > Apply visual transform

$\endgroup$
3
  • $\begingroup$ Tried your solution, and it says that because my objects are multi-user, transforms cannot be applied (for all transforms). Apply visual transform does nothing in my case. $\endgroup$ Apr 4, 2020 at 1:50
  • $\begingroup$ Are you sure you actually select Apply Visual Transform and not any other apply option? $\endgroup$
    – Leander
    Apr 4, 2020 at 13:27
  • $\begingroup$ I believe you are correct. Apply Object Transform doesn't work, but Apply Visual Transform does (though it doesn't help). However, your solution does work if followed by Remove Rigid Bodies. $\endgroup$ Apr 4, 2020 at 17:00
1
$\begingroup$
  1. Create the simulation
  2. step to the desired frame
  3. In the 3D Viewport, under Object > convert to > Mesh from Curve/Meta/Surf/Text

This create the copy from the simulation

$\endgroup$
1
  • $\begingroup$ (Blender 2.92) Make sure to select "keep original" after step 3 in the pop-up dialog in the 3d viewport if you want to retain a copy of your objects with simulation applied. $\endgroup$ May 6, 2021 at 19:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .