3
$\begingroup$

Before I put in "studio lighting" (I followed this simple studio lighting tutorial, with 1250W area lighting from top, left, right) the metal texture looked quite good, however, once rendered in cycles the color seems to flatten/darken and not stay very "metallic" or textured:

enter image description here

The metal still looks alright in materials preview:

enter image description here

Wondering what can i change in lighting or shading so that the render looks more similar to materials preview, maybe even brighter without blowing out the colors?

$\endgroup$
1
  • 3
    $\begingroup$ What kind of metal? You issue is basically the lighting. The environment is kind of black (at this angle) in your render so make sure that's set up correctly. $\endgroup$ – brockmann Apr 2 '20 at 10:26
3
$\begingroup$

The materials preview is not, by default, an accurate read of your lighting because it uses an HDRI (high dynamic range image) to create the reflections you are seeing in the preview.

To fix this, open the Viewport Shading drop-down menu and (with Material Preview selected) you will see the two checkboxes for Scene Lights and Scene World. In this window, you can check Scene Lights to reflect YOUR scene’s lighting and Scene World to switch from the default HDRI to YOUR scene’s world (which I’m assuming doesn’t contain an HDRI).

The angle you are looking at, combined with mostly flat surfaces, without an HDRI, are what’s causing the flatness.

To fix this, start by beveling the edges of those sharp corners (it will add realism too). I would suggest adding a Bevel modifier to accomplish this.

Second, look into adding an HDRI so that the flat surfaces have something more nuanced to reflect.

Third, just make sure that your material’s Roughness value is low (.01 to .4ish) as well.

Fourth, in your Eevee settings (unless you are rendering in Cycles), make sure Screen Space Reflections is checked.

Hope this helps.

John

$\endgroup$
1
  • $\begingroup$ Thanks so much, each piece of advice really helped! $\endgroup$ – mig Apr 2 '20 at 21:16
0
$\begingroup$

You can use any of Blender's pre-packaged lighting environments in your scene.

Example:

  1. Starting with a basic material on Suzanne, looks great in Material PreviewImage with basic material in Material Viewport Shading
  2. Scene doesn't look right in Rendered PreviewRendered Viewport Shading doesn't look right.
  3. Create a split screen, and change one area from 3D Viewport to Shader Editor.Drag corner to create a split screen in Blender Viewport
  4. Toggle Shader Type from Object to World.Change from Object view to World view.
  5. Ensure Node Wrangler Add-on is enabled (Edit--> Preferences--> Add-ons--> Node Wrangler)Enable Node Wrangler
  6. Select the Background node and press control - T (3 new nodes should "pop" up)
    Click "Open" on the Environment Texture node to locate the HDRI Node Wrangler Control-T
  7. Navigate to wherever you have Blender stored on your machine to find the directory with Blender's lighting environments.
    EX: Program Files/Blender-3.0.0/3.0/datafiles/studiolights/world
    And now you can choose any of Blender's 8 HDRI environments available for your render. Navigate to wherever you have Blender stored on your machine.
  8. Now switch to Render Preview in the Viewport Shading tab to see Blender's HDRI environments activated in your scene.Switch to rendered mode in viewport shading
  9. Render the image out to see the effect take place.Rendered image in Blender

Source: Using Material Preview Lighting For Your Renders in Blender

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.