0
$\begingroup$

enter image description here

Ultimately, I am trying to subdivide my current model, but I can't until I clean it up. Subdividing without cleaning causes crazy protruding vertices everywhere.

Using Blender 2.8, I've begun the journey of cleaning my model by first removing duplicate vertices within the model. As soon as I do however, the model has crazy protruding lines as show above when in sculpt mode.

Solutions I've tried:

  • grabbing and smoothing the crazy protrusions for hours. it never seems to end up properly, not to mention, some of the lines seem to go into infinite space.
  • removing the faces in edit mode and then readding them. This is a terrible idea, it garbles up the model significantly.
  • Seeing if I can add vertices in edit mode to get rid of any triangles while maintaining other quads

I'm at the point where I wonder if I should just start from scratch again because I have no idea where I went wrong.

Note: I've added a link to my .blend file

EDIT: Re-uploaded my .blend file to the point before I merged my duplicate vertices

$\endgroup$
0
$\begingroup$

Welcome to Blender Stack Exchange!

See the edits below for an answer to this specific problem. Note that the eventual solution may not apply to all cases of this issue.

I have some bad news. This is a known issue with the Multiresolution modifier, and one that I have encountered many times. I think the next version of Blender is going to have a fix, but the test build I tried still has the problem.

The Multires modifier works (I think) by storing information about how the vertices it adds should be positioned relative to the ones that exist. When you change the ones that exist, it gets confused, and doesn't know where to put the vertices it generates, thus sending them off into infinity like you see. For this reason, it's best to not change the mesh once you've added a Multires Modifier. Specifically, merging and adding vertices that changes the flow of the mesh causes the most problems.

For your file, I tried deleting some sections and rebuilding them so that the modifier recalculates where the generated vertices should be placed, but couldn't get it perfect. In your case, it looks like restarting may be the best option. However, Blender has various backup files that may get you to a point before you changed the mesh. You can recover your last session, try an autosave, or check out the .blend1 or .blend2 backup files. There's questions about those on this site.

Going forward, it's best to not change the mesh when using the Multires modifier. If you have to, use the Apply Base button on the modifier before changing anything. This makes the mesh match the sculpt better, and reduces the chances of things going crazy. In your file, it was too late to try this, and that button made it go much worse. However, at least for right now, the Multires modifier limits your ability to change the mesh. Merging vertices or removing edges like you have will almost always mess it up.

For this specific instance:

For this specific case, there is a possible solution that avoids restarting. You can easily retopologize this model and clean everything up. It's a bit of work, but not bad at all.

Let's start by looking at the model in the file provided. I've circled areas where I immediately see problems.

enter image description here

Entering edit mode and removing doubles finds a bunch of duplicates, but causes the problems you're seeing. The top of the right leg also has a face inside the mesh that is causing issues.

So the original mesh is probably not salvageable while keeping the Multires, at least not easily.

What we can do is copy the mesh, get rid of the Multires, fix it up, and then Shrinkwrap it onto the sculpted one. This will give us proper geometry and fix all the issues.

To start, I copied the object, hid the original with H, deleted the Multires on the copy, and headed to edit mode. The first thing I did was delete half of the mesh, and add a mirror modifier with clipping enabled. I prefer this way over using the edit mode X-mirror option. This also allowed me to get rid of the face inside his right leg, as I removed the right side of the object. Then I removed doubles, and fixed any faces that weren't four sided faces (quads).

Which looks like this now:

enter image description here

Good geometry is important when modelling and sculpting, but takes some practice. It's always best to avoid triangles and ngons (faces with more than 4 vertices) as they do not subdivide well.

Next step is to show the original with Alt+H and delete the face inside the top of his right leg. This doesn't affect the Multires at all, but causes problems later on otherwise.

Back on the copied mesh, I added a Shrinkwrap modifier and set the original as the target. Make sure it's below the mirror modifier.

This will now stick the copied mesh onto the original. However, since the original is sculpted, the copied mesh doesn't follow the original very closely. This causes some issues with the Shrinkwrap, as it tries to find the closest point on mesh to snap to.

It's especially obvious on the feet, as it sticks to the top of the feet instead of the sides.

enter image description here

So back to edit mode on the copied mesh. Using proportional editing, enabled with O and using the scroll wheel to adjust the size, I moved the mesh around to follow the sculpt better. It doesn't have to be perfect.

Now the copied mesh looks like this:

enter image description here

At this point I also checked the mesh to look for any other issues. I did this by adding a Subdivision Surface modifier with the view set to 2. Any points with issues will show up as pinching or sharp points. I found an issue at the wrist, where there were some extra edges inside, so I deleted those. Then I got rid of the SubSurf modifier.

At this point, the mesh is clean. If the goal is only to fix the basemesh, you're done. Apply the modifiers, and make sure that the object is truly symmetrical, as the shrinkwrap often makes things asymmetric. I did this by just deleting half the mesh, setting the cursor at the center of the world and, setting it as the pivot point. Then I selected everything that should be in the exact center of the character and scaled it on the x axis to 0. Then I added and applied a mirror modifier to get the whole character again.

The modified .blend file with the fixed basemesh:

EDIT 2: Saving more detail:

Continuing with the edited basemesh created above, even more detail can be saved based on what you're next steps will be.

In order to keep this symmetrical, I'm going to start by deleting half the character again. This way I only have one half to worry about, and I can just mirror it again later.

I'll start by adding a SubSurf modifier again, and setting the view level to 3 like what you had before. Then I can add a Shrinkwrap again, with the original sculpt as the target.

enter image description here

Looking good.

It's not quite perfect, as the target for the shrinkwrap wasn't quite perfect, but it's nothing we can't handle.

From here, we can apply both the Subsurf and the Shrinkwrap, in that order. This will make all the vertices that the Subsurf generates real, and thus will make the mesh a lot denser in edit mode. This isn't ideal, but it could be worse. I would highly recommend making sure that your geometry is exactly like you want it to be before applying this modifier. Maybe even watch ahead in the video you're following to make sure you won't have to make any changes later on.

Once you're happy with the geometry and have applied the modifiers, we can get the whole character back. In edit mode, with the cursor at the world origin and set as the pivot point, Alt click the edge loop on the edge of the character and scale it to 0 on the x axis to snap everything in line with the exact center of the character.

Then we can add one final mirror modifier, and enable clipping again. There's a few issues in the mesh where it didn't snap properly, or where the original mesh was messed up to begin with. A few strokes with the smooth brush and a bit of repositioning with the Grab brush and it's looking good again.

You can apply the mirror modifier now, or keep it. If you're eventually going to use a Multires again you should apply it.

And that's it! Here's the final result:

enter image description here

The final file is included at the bottom of this answer as well. Feel free to use it, inspect it, or do with it as you please. From everything I've seen you should be good to go with the course!

| improve this answer | |
$\endgroup$
  • $\begingroup$ Hi Brenticus, first, thank you so much for taking the time to help. I fortunately do have a copy of the project prior to merging vertices: drive.google.com/open?id=1guyUaC5mlULgItcxy5VagDTIE4Ujw3Fp - however I didn't find any active modifier on my model when in object mode (forgive me if I'm wrong, this is my first project). Is that copy of the project still too late? $\endgroup$ – syntacticsugga Apr 1 at 18:56
  • $\begingroup$ Unfortunately I cannot open that file. The preferred place to upload blend files on this site is here: blend-exchange.giantcowfilms.com. Then copy the link and add it to your question. $\endgroup$ – Brenticus Apr 1 at 19:00
  • $\begingroup$ Thank you for educating me Brenticus, I've updated my main question link $\endgroup$ – syntacticsugga Apr 1 at 19:08
  • $\begingroup$ I've added some edits that get the base mesh cleaned up. If you're interested in ways to keep the sculpted detail I can try some of those as well. Are you planning to animate this character? $\endgroup$ – Brenticus Apr 1 at 20:39
  • $\begingroup$ Awesome steps and explanations! I really hope someone else can benefit from your post as well. I do intend to animate this character and import it to Unity as part of a tutorial I'm doing on Udemy. $\endgroup$ – syntacticsugga Apr 1 at 20:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.