0
$\begingroup$

In my fluid simulation all inflows are disabled until around frame 620. There is absolutely no fluid in the scene up until this point.

enter image description here

I would have thought that the fluid simulator would quickly process these frames and skip them since it would be trivial to determine that there is no fluid to simulate.

However, during baking these frames are taking as long to process as a frame full of fluid would. It seems like it is going to take blender an hour to "bake" 600 frames with zero fluid.

Is there any way to make blender skip the processing of these frames and only start the actual simulation at around frame 600?

$\endgroup$
2
$\begingroup$

The speedup is possible:

Update based on comment for Blender 2.81a:
(To my best knowledge, as it is a good bit more complex.)
enter image description here
This older version does not use Mantaflow, means it's still using the older fluid solver, which takes it's Time Start and End values as Seconds and not frames.

There is a bit more to the simulation with the old solver:

  1. Time Start and End are values expected in seconds
  2. Using any value higher then 0 as start essentially means the simulation skips the time til then and the result will be like starting in the middle of a movie.
  3. The time between start and end (default 4 seconds) is stretched/squished according to the timeline given Start and End. Lets say start frame 1 and end-frame 200 with 25 fps, would mean the 4 seconds would be simulated over 200 frames.
    Essentially stretching it as 200/4 is 50 and not 25 fps. So to have the speed correct we would need to set End to 100. If the simulation is set to end at 8 seconds, 200 frames would be right, different fps though can make this equation a bit tougher.
  4. After the simulation is baked, it can be played with an offset, means then you can use a positive offset to start the simulation again somewhere(depending on the frames given) from the middle, or use a negative value to delay the simulation and start it later then it was calculated for. "-25" would make it then start 1 second later at frame 25. (Why at one hand seconds and on the other side frames are used, is beyond me.)
  5. Last but not least, there are 2 other places you may need to visit and adjust:
    enter image description here
    Making the timeline show seconds as to have a better indicator for how long the simulation may go and
    enter image description here
    the Output Properties to adjust the "Frame Rate" with it's "fps", as that influences the timeline as well as the calculation you may need to do to figure out what to set the simulation end and later offset.

Friendly suggestion, I'd update to the new stable Blender version 2.82a with Mantaflow if possible, as below shown the setting up became a lot easier: You may not only have to time the inflow(s), but also set the Frame Start in the domain. See picture below, the frames that will be calculated, be there fluid or not, are set in the Cache Section. All in frames.
enter image description here
Version 2.82a+

While you can always cut off the inflow, the simulation is stubborn and goes through all frames between Frame Start and End when you bake.

Happy Blending

$\endgroup$
3
  • $\begingroup$ Thanks for the answer, but I have completely different settings in the domain physics properties tab. I am on blender 2.81a. $\endgroup$ Apr 1 '20 at 15:45
  • $\begingroup$ I would not mind to add to, or correct my answer if my knowledge was not deep enough. We all learn new things, so i would highly recommend the newer version as Mantaflow is really simpler to set up and it allows a very nice preview instead of having to bake everything to then look and maybe having to redo it. I already wrote an answer based on Mantaflow here I am trying to fill a bottle with liquid, maybe helpful after updating Blender, Youtube has a lot Mantaflow tutorials as well. $\endgroup$
    – Xylvier
    Apr 1 '20 at 19:08
  • $\begingroup$ I ended up just bearing with the long simulation times as there does not seem to be a good way to solve this problem in 2.81 and this is for a time constrained project where I do have the time to upgrade blender and learn / convert to the new mantaflow system. I have accepted your answer though because I see that the solution to this problem is essentially just "upgrade to 2.82". The new mantaflow system looks very nice and I will certainly be upgrading and experimenting with it once this project is complete. $\endgroup$ Apr 2 '20 at 10:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.