2
$\begingroup$

Whenever I try to do a fluid simulation, the fluid domain remains visible. I have tried:ctrl+a-scale, turn on/off visibility for render/viewport Here's a video demonstrating my problem: https://youtu.be/XmiTU2B_nYU Here's the blend file in case I have messed up some settings: https://drive.google.com/open?id=1EIv2pACFD-i5CnuuONOKpnezSUYuREFz Thank you for any help!

$\endgroup$
1
  • $\begingroup$ In the new fluid system you have to bake the mesh after the simulation in the domain's tab. $\endgroup$
    – FFeller
    Mar 31, 2020 at 18:55

2 Answers 2

4
$\begingroup$

Based on your video; you are roughly here;

enter image description here

You first step should be to enable, then bake, the mesh;

enter image description here

(Note: My image shows "free mesh" on that button, because I've already baked it)

Now, turn off the liquid;

enter image description here

And you should now have this;

enter image description here

$\endgroup$
1
$\begingroup$

Other way to go is disabling particles visibility themselves. I have just had exactly identical issue while trying to render in viewport. This happens because Physics Modifier creates particle System. The another visibility setting you are looking for is in particle systems tab.

Keep in mind that Disabling liquid (at least in my specific case) may change look of final resulting mesh. Maybe in my case i fiddled a lot with too much settings to achieve my desired result and disabling liquid changed the geometry of the mesh.

enter image description here Before: Blue Particles are visible in rendered view and devlook.

  1. Go to Particles Tab on your Domain object. Pay Attention to Blue dots clipping through liquid mesh in the picture Before(blue particles visible)
  2. Expand Viewport Display And choose None in "Display As" optionchanging option
  3. After. Refer to first picture to confirm difference No Mantaflow visualisation particles.

Why i am posting it ? Disabling liquid changes final resulting mesh. Maybe in my case i fiddled a lot with too much settings to achieve my desired result and disabling liquid changed the way the final mesh looked.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.