1
$\begingroup$

I've made particle system based on single feather alpha and to color it I used color map based on main object. Since it has UDIMs I used them as well, just scaled color map to 512p to save space. All worked just fine in viewport, but when I decided to make test render - it was all wrong. To make it more interesting the other particle systems which only used paths, had correct colors in correct places. I tried everything, and finally found solution - I isolated texture tile mapped to main body, where most of the object particles were and it suddenly worked.

Could someone explain to me what's happening here? Why this particular fix worked? Are UDIMs not compatible with object particles?

First render with distorted texture on object particles, but working alright on path particles

"fixed" texturing on object particles, by isolating main torso tile from UDIM set

UDIM set with feather color map. Torso tile - 1002

Everything looking fine in viewport

$\endgroup$
  • $\begingroup$ If it's working in the viewport there is no reason why it shouldn't work for the final rendering. Maybe a screenshot of your particle settings help solving the issue. $\endgroup$ – brockmann Mar 31 at 16:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.