1
$\begingroup$

luxcore vs cycles

All flattened cubes have the same Bevel modifier settings, except for the left one, which has Harden Normals checked. The faces of the left two object are smooth shaded, the right object has flat shaded faces.

I want to use the custom normals created by the Bevel modifier in LuxCore. The result is supposed to look like in Cycles.

Using BlendLuxCore, how can I use the custom normals created by the Bevel modifiers Harden Normals option?

$\endgroup$
  • $\begingroup$ Since this ticket was closed recently, you may want to test the current master branch of BlendLuxCore which is supposed to include custom normal support. There are two commits which are supposed to implement this: github.com/LuxCoreRender/BlendLuxCore/commit/… and github.com/LuxCoreRender/BlendLuxCore/commit/…. I haven't tested this myself, which is why I'm posting this as a comment. $\endgroup$ – Robert Gützkow Mar 30 at 19:33
  • $\begingroup$ Fantastic, thanks a lot. I don't understand how I could have overlooked that issue. Add an answer and I'll accept =) . My version was older than 11 hours, but I have now updated it. $\endgroup$ – Leander Mar 30 at 19:59
0
$\begingroup$

The ticket for custom normal support in BlendLuxCore was closed 2020-03-30 10:39 CEST. Basic support for custom normals is supposed to be implemented. However, the result doesn't match the Cycles render yet. The render with and without harden normals appears to be identical, only the auto-smooth seems to take effect.

Cycles Cycles

LuxCore enter image description here

The following commits should have implemented support for custom normals:

Project file

The project does not include the HDRI. It can be downloaded from HDRIHaven.

| improve this answer | |
$\endgroup$
  • $\begingroup$ My results are identical. Are you sure you downloaded the latest build? $\endgroup$ – Leander Apr 1 at 13:56
  • $\begingroup$ @Leander Doesn't work for me and I'm using the latest build from their GitHub release page. Great if it works for you though. Perhaps you're using slightly different settings? $\endgroup$ – Robert Gützkow Apr 1 at 14:04
  • $\begingroup$ Added the blend, switching between lux & cycles shows the same render in the viewport on my setup. $\endgroup$ – Leander Apr 1 at 14:31
  • $\begingroup$ @Leander Here is my project file. The auto-smooth angle in your project is quite extreme. $\endgroup$ – Robert Gützkow Apr 1 at 14:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.