2
$\begingroup$

What do I when I have a model that I am painting on, the texture has an alpha layer, and I want to do something like paint the color black over some other color on that texture. when I do this of course the color black just ends up making any other color on the texture invisible. So is there way to paint on an alpha texture with the color black and have it show up instead of alpha things out? I'm trying to do this using nodes in blender 2.82.

$\endgroup$
  • $\begingroup$ Did you use a Transparent BSDF and a Mix Shader for the material? $\endgroup$ – FFeller Mar 30 at 17:17
  • $\begingroup$ no but I will try that now, thanks for asking $\endgroup$ – Taylor Mar 30 at 17:22
  • $\begingroup$ Ok, while i was trying out your suggestion, i found the reason it wasn't showing up while i painted on it was because I needed to also change the objects blend mode to alpha blend instead of Opaque. this seems to have solved my problem. I think it did anyway, ill have to mess around, for a minute to see if it really does what I wanted it to do $\endgroup$ – Taylor Mar 30 at 17:53
  • $\begingroup$ Hi Taylor, welcome to blender.se. If you think you have found a solution, I'd be happy if you added an answer to it in the answer box below. It is quite common to answer your own questions and would help others with the same problem. $\endgroup$ – Leander Mar 30 at 18:37
0
$\begingroup$

in the end, i got it to show by turning the blend mode in the materials settings to alpha blend, then i could see the color black as i painting on the model.

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.