0
$\begingroup$

I'm experiencing an issue when rendering my scene. In render preview the 'ceiling' and 'ceiling lights' are visible, but when I render, those two are missing.

I'm new to Blender and I'm using 2.8. The layers both have "Disable in renders" unchecked and I'm using Cycles.

Here is the link to the file: https://www.dropbox.com/transfer/AAAAALaJJeb2UOxFH6RPAOVJtCCByFAn1MeG4opLutcf1uJsmVycv20

Appreciate any help

Render preview Rendered image

$\endgroup$
  • 2
    $\begingroup$ You've likely hidden objects in the viewport (eye icon) without hiding it in the render (camera icon). That object is blocking the view on the ceiling. $\endgroup$ – Robert Gützkow Mar 29 '20 at 13:55
  • $\begingroup$ Please use blend-exchange.giantcowfilms.com to attach blend files. This will ensure the link won't expire. Thx $\endgroup$ – Bruno Mar 29 '20 at 14:01
  • $\begingroup$ Thanks Robert. This has fixed the issue :) And thanks Bruno, I'll use that link going forward to attached files $\endgroup$ – Greg3D Mar 29 '20 at 15:48
1
$\begingroup$

The comment above by Robert was right. Your Aisle 6 (hidden in viewport but not in render) is blocking your camera. Disable Aisle 6 from render and it'll render fine.

enter image description here

$\endgroup$
  • $\begingroup$ That's brilliant, working perfectly now. I've been tearing my hair out with this. $\endgroup$ – Greg3D Mar 29 '20 at 15:46
0
$\begingroup$

Your Ceiling Z:

Your Ceiling Z

Your ceiling Light Z:

Your ceiling Light Z

they are in the same position. Lower your ceiling lights Z. you'll get with Area lights reduced...

Cycles Render

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.