1
$\begingroup$

enter image description here

As shown in the picture, even the cube is rotated, its Gizmo still aligns with global axes instead of local ones. Even when I have set Transformation Orientation to "local". Is it possible to display a local Gizmo?

Edit:

Strangely, when I choose "Move" or "Transform" tool, the Gizmo doesn't follow local axes.

enter image description here

But when I choose "Rotate" or "Scale" tool, without changing any other settings, the Gizmo looks right:

enter image description here

Now it seems like a bug to me. Or is there anything I missed?

$\endgroup$
  • $\begingroup$ Hello :). This could help blender.stackexchange.com/q/170977. Or if it's individual faces, then this could help. $\endgroup$ – Jachym Michal Mar 28 at 15:29
  • $\begingroup$ @JachymMichal Thank for your help. While I know I can transform along with local axes with G/S/R+XX/YY/ZZ, I would still like to make my Gizmo to reflect my Transformation Orientation setting. Is ti possible? $\endgroup$ – Lai Yu-Hsuan Mar 28 at 15:39
  • 1
    $\begingroup$ Sure :). When you rotate an object in object mode, the local orientation changes. Did you rotate it in object mode or in edit mode? $\endgroup$ – Jachym Michal Mar 28 at 15:48
  • $\begingroup$ @JachymMichal It's object mode. I noticed some other weird behaviours, please take a look on my edit. $\endgroup$ – Lai Yu-Hsuan Mar 28 at 15:52
  • $\begingroup$ Oh :). This does indeed look like a bug. Including the thin gizmo lines and weird viewport visibility. It'd be great if you reported it through Help > Report a bug. Until it gets fixed, probably switching to 2.81 or 2.83 could help. $\endgroup$ – Jachym Michal Mar 28 at 15:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.