2
$\begingroup$

This is my composite setup. From all tutorials, wikis, etc, this should place the movie clip in the background and the wall/thing in the foreground. Does anyone have any idea what I'm doing wrong?

$\endgroup$
2
$\begingroup$

Your nodes are correct, but how can you see through the "walking/thing" layer if your walking/thing render is fully opaque? You need a transparent background for that.

If what's behind your objects is only the world environment, then the simplest way to get transparency is to head over your render tab, Film panel and check the Transparent option:

enter image description here

| improve this answer | |
$\endgroup$
1
$\begingroup$

You forgot to make the world background as transparent. To do so, go to Render Properties > Film > check Transparent.

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.