0
$\begingroup$

My last post of this was marked as a duplicate for glass shaders. I want to make explicitly clear, I am NOT asking for glass shaders. I'm doing a bit of archviz for a buddy's bathroom remodel, and I want the windows and reflective surfaces to show a background without it darkening the scene. In 2.79 you could set the object ray visibility, but that seems to have been removed. (As shown in this post; Plane to only reflect object?) I know I could use view layers, but next to a window is a glass plane that reflects the environment, and I don't know how I'd composite that in. I've also added in an external ground plane to get some ground color bounces. By the end result, I want the brightness afforded by the background plane NOT being there, but have it appear in the final image and reflections. Note the reflection in the glass enter image description here enter image description here

For a simple demonstration, I made a plane and some glossy spheres with an HDRI, I need the light to pass through the plane and reflect off the lower sphere underneath it, without it also creating a shadow from the plane. In the scene I have the light should be passing through the plane without the plane casting a shadow and darkening the scene.enter image description here

$\endgroup$
0
$\begingroup$

Is it possible you're on Eevee (doesn't look like it from the noise), but that hasn't been removed: enter image description here

For much more control I would suggest the Input -> Light Path node

| improve this answer | |
$\endgroup$
  • $\begingroup$ Oh my god. It was just hidden in a sub menu. Brilliant. Unfortunately, it still makes a shadow cast over the scene, so it's not as clear cut as I'd hoped. And I'm not brilliant with the light path node, but I'm trying to figure it out. $\endgroup$ – JZStudios Mar 27 at 18:44
  • $\begingroup$ I'd need to see a not so noisy result with the "shadow" marked in order to help you there. In theory unticking shadow removes that but there are other effects contributing to darker areas, as AO and GI. $\endgroup$ – Frederik Steinmetz Mar 27 at 19:31
  • $\begingroup$ I think with the little demo scene I added in, it looks worse than it is... In my actual final scene making the background image only have glossy visibility results in something much closer to it not being there. Any darkness could possibly be attributed to just reflecting a darker image. $\endgroup$ – JZStudios Mar 27 at 19:35
0
$\begingroup$

Huge thanks to Frederik, I must've been in the Eevee mode or something, because that option was not there, thanks for pointing it out. Making the plane glossy only very slightly darkens the scene, but not nearly as much as otherwise, while still giving me the reflections I want and then I can simply use the transparent option in Film under Render properties to make the sky alpha and composite in another view layer with the background image to get the end result I want.

| improve this answer | |
$\endgroup$
  • $\begingroup$ if it's only slightly, I'm guessing you are missing the diffuse bounces (GI) that would otherwise softly reflect the lights inside your scene. If you ask me, leave it, it's more realistic. $\endgroup$ – Frederik Steinmetz Mar 27 at 21:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.