1
$\begingroup$

I'm trying to do as Ian Hubert does in his -now famous- blender speech at BCON19.

https://www.youtube.com/watch?v=whPWKecazgM

At 3.47, he 'import images as a planes' then extrude it. I try to do the same, but Blender doesn't react the same at all.

When I extrude my wall photo, it just gets semi transparent in a strange way, as if it was hollow. When I do an edge loop a part of the picture just disappears.

On the right the original pic, on the left the same plane that I extruded and loopcutted vertically in the middle.

extrud loopcut wall

What am I doing wrong? Thanks for your help.

$\endgroup$
3
  • 1
    $\begingroup$ understand "Hello!" is gone as the first line of my message :) $\endgroup$
    – Pyra_M
    Mar 27 '20 at 10:15
  • $\begingroup$ Hi :). Salutations like 'Hello' are removed from posts automatically. Nothing we can do about it. $\endgroup$ Mar 27 '20 at 12:01
  • $\begingroup$ good to know... $\endgroup$
    – Pyra_M
    Mar 27 '20 at 13:05
0
$\begingroup$

There are two things to prevent those transparent faces.

  • For Cycles - add some thicknes to the whole wall, before extruding individual parts
  • For Eevee - Set material Blend Mode to Opaque

Cycles - add thickness before extruding. Just extrude the whole plane first.

enter image description here

Eevee - set blend mode to Opaque

enter image description here

$\endgroup$
3
  • $\begingroup$ OK, it gets better when I put this blend mode Opaque indeed, I will try a bit more to see if everything gets fixed. thanks $\endgroup$
    – Pyra_M
    Mar 27 '20 at 13:11
  • $\begingroup$ Happy to help :). If it fixes your problem, please mark the answer as accepted . Thanks :). $\endgroup$ Mar 28 '20 at 15:27
  • 1
    $\begingroup$ it worked fine thanks again $\endgroup$
    – Pyra_M
    Mar 31 '20 at 12:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.