0
$\begingroup$

Good evening,

I am fairly new to Blender. I have been unsuccessfully attempting to create a curved cylinder (i.e. a pipe) to follow a curve path. When I go to Geometry > Bevel > Object > Bezier Circle (applying it, as all the videos and guides say to do) I end up with the image below. For some reason whenever I move the vertex point(?) it does not move the piping around like all the video guides do. Instead, it extrudes the object and creates the monstrosity you see in the image.

Far left object is the path with the Bezier Circle applied. (Path next to it is pre-bevel application).

As you can see in the path (far right) with the bezier circle applied, it works fine, so long as I do not attempt to move the pivot points [vertex point?].

Basically the goal is to create a path that I can then apply the object bevel (circle) to it. Creating what looks like a pipe.

enter image description here

enter image description here

$\endgroup$
  • $\begingroup$ Hey there and welcome, it helps if you use certain keywords, but maybe this does solve your problem why-cant-i-create-a-pipe-from-this-curve? $\endgroup$ – Xylvier Mar 26 at 2:28
  • $\begingroup$ I tried that method, 1: the thread you provided uses the old blender. 2: my circle and path (NurbsPath) is flat on the Z axis. As you can see in picture two, when I move the bottom point to the left it extrudes the circle on the long end, rather than turning the circle along the path. $\endgroup$ – ItsRainingHP Mar 26 at 3:23
  • $\begingroup$ While i hoped it would have a solution for you, situations can be different. That said, would it be possible to share the file, you can use Blend Exchange. It may help to take a closer look. Also just in case, you can remove all that is not related to the problem to make the file smaller, please. $\endgroup$ – Xylvier Mar 26 at 4:39
  • $\begingroup$ Absolutely, thank you for taking the time to help me. I went ahead and added the Blender file with the objects in my screenshots for your review at the end of my original post. Any help is appreciated. $\endgroup$ – ItsRainingHP Mar 26 at 13:50
0
$\begingroup$

Checked out the file and was first rather surprised by how fast any slight movement of a point from the curves made a mess. Then if you think about it, small movements resulting in a very big mess very fast ... there is something wrong with the translation of action and reaction .. yes the scale.

I checked and pretty much all curves even the circle (responsible for the size of the pipe diameter) had it's scale not applied. Or shall i rather say it was scaled in object mode, which is something pretty much everyone does and regrets later, more so when working with curves.

This:
enter image description here

Shows that the circle was scaled and the new scale was not applied, which for a straight path does not result in anything other then a thinner pipe.

Fixing this:

  1. Press Ctrl+A -> "Scale"
  2. Go in edit mode
  3. Afterwards open the Sidebar with N and find the Transform panel, usually the top one.
  4. Under Mean Radius it should be standing "1", but due to the previous steps it got changed to "4.123", set that back to "1" like so:
    enter image description here
    Circle profile fixed.

Now to the curves/paths.
There are a few things that need adjustments:

enter image description here
First it looks like this

  1. The scale needs to be corrected, BUT here you need to be careful, as to not change the scale with the bevel object included!
  2. Thus in the options, remove the Bevel Object resulting in this:
    enter image description here
  3. Now there are 2 things marked, rotation and scale. While we could just apply those, it would nip us in the butt afterwards, so believe me and do the following.
  4. We have to leave the rotation alone! Applying it would mess with the sizes of the path internally.
  5. And regarding the scale we have to do it manually.
  6. Go in the Transform panel and change the value of the X-scale to 1. Just keep in mind it was 25.
  7. After adjusting the scale the path will become very short 1/25th to be precise, so go in edit mode and press A selecting all elements, followed by S and then type in 25 followed by Enter. Resulting in the old length, without all the trouble.


    Here is what would have happened if we had applied the scale or rotation or both, changing the path dimensions, thus causing more things to fix:
    enter image description here
    I know all can be fixed somehow, but let's fix to not have to fix the results, if you know what i mean ;)


Here how it does look now:
enter image description here

Now there are some settings you need to deactivate that only show their effect in edit mode, assuming that you want to have the pipe start and end with the path/curve and not generate a circle (endpoint connects to the startpoint, responsible for some of the weird shapes).

  1. Deactivate the Cyclic U and Bezier U to get something like this:
    enter image description here
  2. As you can see the path is having it's normals along it's entire length, means with the Bezier circle applied as Bevel Object you now get something like this:
    enter image description here

With this all done you can now move the points and get the expected results like shown here:
enter image description here


Ok long story short, scale is very important to pay attention to, if you want to adjust the sizes, it's recommended to do so in edit mode. Rotations i would also consider to adjust edit mode, as it can also cause issues, especially with the profile curve.

The other curves may have one or more of the same issues, but i believe if you followed the steps you should be able to handle those yourself now. Just beware, there you need to scale only in one direction.

When done, it should look like this:
enter image description here

All the steps you could have saved yourself by starting over with scale in mind, but since we are supposed to learn from mistakes, i believe it's good to know how to fix things and understand what caused the problem along the way.

Happy Blending.

| improve this answer | |
$\endgroup$
  • $\begingroup$ Amazing, thank you sir. I did not understand applying the scale. Thank you for this very detailed explanation. The shortcuts for Blender still allude me. I will have to find/create a cheatsheet. $\endgroup$ – ItsRainingHP Mar 26 at 18:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.