enter image description hereas it is seen in picture, i can't select whole mesh - three squares are not selected. So, as i'm a beginer, i think that is the reason that UV Squares plugin doesn't work. I tried it with another mesh and it worked. what can i do? enter image description here

Thanks, gregork

  • 1
    $\begingroup$ Hello :). The whole uv island is selected. The grey-ish face is active face and those two missing are cutouts for the cup handle. $\endgroup$ Mar 25, 2020 at 23:52
  • $\begingroup$ Aha:) ok i get it. tnx! still, have some ideas, why uv square plug in doesn't work in this particular mesh. $\endgroup$
    – GregorK
    Mar 26, 2020 at 8:04

1 Answer 1


Check the inside of your mesh. Either you have a face inside the mesh or they're multiple vertices in one spot. Select all and press M > Merge By Distance. Unwrap mesh again. If there is a face inside the mesh, delete it and then unwrap it again.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .