How do I stop Blender from forcing an existing keyframe position while I'm trying to move the object/bone to set a new keyframe? This seeming position/screen refresh is slowing me down. (Note: "Snap to..." is not enabled.)

The steps I'm doing to set a keyframe:

  1. I Select the object/bone with Right click and then set a LocRot or LocRotScale key using "I" on the keyboard.
  2. I move along the timeline and Select another object with right click.
  3. I re-select the 1st object/bone via right click
  4. I press the "R" key on the keyboard to rotate the object to a new position. But the Object/bone refuses to rotate. It WILL rotate toward my mouse but flitters back and forth between it's keyed position and the new position. As soon as I release my mouse the object/bone "snaps" back to the keyed position.

As long as I don't have a keyframe on an object I can move/rotate it wherever I want. However, once I set a keyframe I can't re-position said object/bone in the 3D-Viewport (using the mouse OR the sliders). I'm forced to set a new keyframe before re-positioning, and to change the keyframes in the Graph Editor one channel at a time. This is hardly time saving or an organic workflow for animation.

I've had this problem with Blender 2.78, 2.79, and now even after buying a new computer in 2.81. I've shut down the program and re-started the project in 2.82. Here is The current Blend File I'm having an issue with:

The culprit at the moment is the empty named "_CameraPivot." The "force keyfrsme refresh", or whatever it really is, is not happening at the moment but I anticipate it will happen again. Even restarting the program and re-opening project in 2.81, even after saving the project in said state, results in the "force keyframe refresh" being gone. But I can't constantly be shutting down my workflow and restarting the program every time this problem raises it's ugly head.

I can't help but think there is some hidden command key for this as a function which I'm not aware I'm pressing (I.E.: Like how pressing the Caps-lock key, toggling/hiding the brush cursor, in Adobe Photoshop is an annoying/panicky thing if you don't know the function exists but a useful tool if you do.).

Is there anyone who can help me with this issue/function? It's got to be a simple thing as it's not covered anywhere I can find.

Here's a video link to the problem I'm having: RecordedVideo

  • $\begingroup$ Hi. I suggest you lay out the exact steps you are doing, e.g. "1. Select an object with left click. 2. Press [keyboard key]. 3. etc.." so we can diagnose the problem because, at the minute, I have a hard time understanding what you mean regarding "The Refresh" and " and "As long as I don't have a key on an object keyed". Thanks. $\endgroup$ Mar 24, 2020 at 18:46
  • $\begingroup$ The object/bone behaves as if I'm trying to move/rotate it while playing a keyed animation. Which is not the case. $\endgroup$
    – Jet Jay G.
    Mar 24, 2020 at 19:12
  • $\begingroup$ Hi. If you have more information to add, please add this to your question by using the edit link. Comments aren't really for extended discussion. Thanks. $\endgroup$ Mar 25, 2020 at 17:57
  • $\begingroup$ Okay all of that is corrected now, Ray Mairlot. Can someone still help me? $\endgroup$
    – Jet Jay G.
    May 11, 2020 at 23:03
  • $\begingroup$ As I said, additional information in the comments should have been added to the question. I have done this now. $\endgroup$ May 12, 2020 at 2:53

1 Answer 1


This is a very odd issue which seems to be caused by the 'Import Images as Planes' add-on. Disable the add-on in the Preferences (and re-enable it if you still want to use it) and the issue should be gone.

That add-on has some code that runs when an object moves, and somehow it's got into a broken state and is trying to update the object positions when you're trying to move them. The problem seems to keep occurring in different versions of blender because the properties that are related to the broken state are stored in your file. Disabling the add-on removes these properties and if it is re-enabled it will set them up afresh in a working state. At least, that's what seems to be happening.

By the way, while that does solve that issue, there are still some other issues in your file, related to the drivers you have set up in the compositor in each of your scenes (which may have been set up by the add-on?). The System Console (Window> Toggle System Console for Windows users) prints out a lot of errors when you change scenes and a lot of the drivers seem to have missing references to objects.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .