0
$\begingroup$

i have these red cylinders that should slide into theseenter image description here slots. It works great in the middle of the object with the slots. But at both ends the red cylinders keep falling through the slots and land on the surface of the object underneath. I added some pics. Maybe someone can help me out. Thank you.

enter image description here

$\endgroup$
  • $\begingroup$ did you add that object as a rigid body? $\endgroup$ – Galactic_Cat Mar 23 at 10:21
  • $\begingroup$ Yes. Both the cylinders and the object with the slots are active rigid bodies. $\endgroup$ – Marc Mar 23 at 10:30
  • $\begingroup$ well then what is the length/size of that cylinder?(from the measure tool) $\endgroup$ – Galactic_Cat Mar 23 at 10:34
  • $\begingroup$ D=0.7m L=2m, But on the first pic you can see it fits inside the slot and doesnt fall through. But it falls through the slots at both ends. $\endgroup$ – Marc Mar 23 at 10:36
0
$\begingroup$

I think you may have edited the object after applying the RB, delete the the current RB sim and reapply with collision type as mesh.

edit:i think I know the problem your object does not move, normally rbs are added to moving objects by default, yours doesn't, causing some problems, i tried recreating the scene and ended up with messing in the sensitivity panel and the dynamics parts, what you want to do is try adding a small amount of sensitivity, and disable the dynamics in it, reply if this worked.

| improve this answer | |
$\endgroup$
  • $\begingroup$ makes sense. But i dont know how to to that. $\endgroup$ – Marc Mar 23 at 11:39
  • $\begingroup$ It also doesnt fall through when the object with the slots is set as passive. With passive everything works as it should. But as active object it falls through but only at the ends. $\endgroup$ – Marc Mar 23 at 12:14
  • $\begingroup$ just do what you did before and change the collision type from convex(weird sphere icon) to mesh(monkey) $\endgroup$ – Galactic_Cat Mar 23 at 18:03
  • 1
    $\begingroup$ I tried it. Didnt work. $\endgroup$ – Marc Mar 24 at 2:52
0
$\begingroup$

Found the answer that worked for me in older thread. Object > Apply > Scale

Worked. Thanks anyway

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.