I am working on creating model in blender that has part of its material transparent. I would like to port it over to Unity to use as piece in my game, however the transparent section is not properly being rendered in Unity. I have unwrapped and baked a UV map, which I then saved in my Unity project. However, the transparent section of the material is not transparent but black. I've tried chaning the rendering mode in Unity to transparent but that makes the whole model transparent. I'm not sure what I need to do to get only the transparent section of the model to render properly. Any suggestions would be helpful. I have provided images of my model in blender as well as in unity with the current material settings. Blender Model and UV Map Model in Unity


1 Answer 1


When working with transparent textures you'll have to set up a separate material in Unity that has it's surface type set to transparent and another material for rendering the opaque parts, In blender you'll have to assign an extra material slot for this transparency the extra slot will show up in the material options for your model in Unity.

Select the parts of the mesh you want to use the transparency and click "assign"

In Blender

enter image description here

In Unity

enter image description here enter image description here

  • $\begingroup$ Alright, that did it. Thank you for your help. $\endgroup$
    – mjbelanic
    Mar 23, 2020 at 3:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .