0
$\begingroup$

I rigged some FPS hands and a gun and started make animations. I'm really struggling import my animation from Blender 2.8 to Unity.

The Animations look fine in Blender like it should, but are messed up in Unity.

don't know the causes of this problem and already searched several hours for a solution.

Changing the compression of the animation in Unity makes this problem less bad, but its still noticeable and for sure not a proper solution.

If you need more info about the project settings just let me know.

$\endgroup$
0
$\begingroup$

The method I use is to select in pose mode all (and only) deforming bones, go to Menu Pose/animation/Bake action, and create a new action, clearing all constraints and parenting, so that the Fbx I'm exporting is a clean rig, with no constraints, associated to the clean mesh. Make a copy of both mesh and rig before any attempt (You'll have to try out some exporting preferences, according to the needs). It works fine.

| improve this answer | |
$\endgroup$
0
$\begingroup$

I believe this is more of an issue with the FBX format and how Unity handles animations not Blender, when exporting your mesh tweak these settings in Unity for your animation try setting the position and/or rotation error values lower to see if it helps with the hand sliding on the guns handle try changing the "keyframe compression" to "optimal" and see if there is any improvement. Unity is attempting to optimizing and compress animation for faster loading times.

In Unity

enter image description here

In Blender when exporting try using settings similar to these,

disable leaf bones export only deformable bones

changing the values for "Sampling Rate" and "Simplify" can also help.

enter image description here

| improve this answer | |
$\endgroup$
  • $\begingroup$ Thank you so much!! This was the right tip. Now the model animates like intended. In Blender I needed to set the"Simlipfy" Slider in the Baked Animation to zero. This caused to problem. Also in Unity the "Anim Compression" -> "KeyFrame Reduction" -> all 3 settings must be set to zero aswell like you said. Thank you again for your fast and right answer!!! I should have asked way earlier :-). $\endgroup$ – John Mar 22 at 22:40
  • $\begingroup$ Please add a check mark to my answer as correct in case others view this question. $\endgroup$ – Chris Mar 22 at 22:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.