1
$\begingroup$

I've been trying to animate fluid simulation from past 3 days, and i've failed. Sometimes inflow object didn't emit fluid, tho it was set correctly, sometimes fluid was c o m p l e t y ignoring my collision object. But today miracle happened and everything is working as expected, my particles instead of something that represent uv sphere are 2D squares(??) despite the resolution is set to 128. Also my cup is dripping a bit (no it ain't bruised). I encountered Xylvier's guide (Jesus what a good man) I am trying to fill a bottle with Liquid that did not help me tho.

My beautiful squares:
enter image description here enter image description here

And link to download whole project:
My Project on Google-Drive

Edit, now when i created new folder to export my blender file, squares transformed to giant uv balls.

Also, i don't know why it is laggy. Every form of help really appreciated.

$\endgroup$
4
  • 2
    $\begingroup$ Suggestion. Place a question with a question mark (?) in the space provided above. A sample question might read as ... How do I get the liquid to fill the obstacle and have not pass through the obstacle? The writing above reads more of tragedy than someone ready to listen to other ideas. Leave the tragedies for the Meta portion. $\endgroup$ – atomicbezierslinger Mar 21 '20 at 23:33
  • $\begingroup$ Your domain should be the tightest fitting 3d-box around your animation that allows you to express your ideas. Do not create unnecessary empty space in the fluid domain. Thin walls of obstacles will leak more. Thicker walls will leak less. Bake the Fluid Simulation. 128 is not necessarily a high number. If this scene is not for a closeup compromises can be made. $\endgroup$ – atomicbezierslinger Mar 21 '20 at 23:47
  • $\begingroup$ I am not asking for the hardware specs of your machine. More CPU Power and RAM, and More GPU Power and GPU Memory the Better. When you do not need to see the FS Fluid Simulation mesh turn off its visibility. FS produce surfaces made of cubes (voxels). Know that to get a smoother FS you can increase the resolution and wait more time to bake. You can also smooth the result later with modifiers. Nothing is for free. $\endgroup$ – atomicbezierslinger Mar 21 '20 at 23:52
  • $\begingroup$ Thank you, I don't know what "meta portion" is tho. If my fluid particles are made of vexels does it mean that it can't get any smaller? I don't get that, my cup is 10cm tall and one cube I like one third of it. What "FS" is? $\endgroup$ – KacperYZ Mar 22 '20 at 0:21
3
$\begingroup$

Solution for Particle size:

  1. Go in the domain cube and select the particle system that is generated in there (Liquid needs to be active in the domain for the particle system to show up!).
  2. Find the Viewport Display Panel and change the Size to 0.001m instead of the 0.01m it was. enter image description here
    There seems to be something that sets the particle size back to 0.01m everytime. Did not happen in a new scene, but i do not know what settings or buttons where pressed in the run of creating the entire scene.

Solution for the cup:

  1. Create a duplicate of the cup, you can call it "Simcup".
  2. Remove all but the inner walls, also the subdivision surface modifier can be set to 2 for both, render and view. It's also a good idea to make the Simcup a child of the original cup, so it sticks to it.
  3. Add a solidify modifier and set the thickness to 0.015m
    enter image description here

  4. To have the simcup not disturb the render and or viewport, go in the Object Properties and there to the Visibility and deactivate the "Show in Render", then in the Viewport Display deactivate "Shadow" and set Display As to "Bounds"
    enter image description here

  5. Now remove the Fluid simulation from the cup. The simcup on the other hand keeps it, as it was copied when you duplicated it.
  6. The Sampling Substeps seem to be a good value with 5 and the Surface Thickness worked well with 0.01
    enter image description here

Suggestion for the inflow:
The cylinder was to big and caused the cup to always be flooded and overfilled. Adjusting it down a bit and reducing the time the inflow is open helps a lot.

And finally the domain, aside the fact that it can be scaled down (in edit mode please), you can change settings and try on Replay mode, for that it's best to set the time on 1 and then deactivate and reactivate the Fluid modifier visibility, seems to be a lot better then deleting the cache every time. Learned something new here too :)

One setting to consider is the Diffusion, where you can use the preset water. enter image description here
After clicking on the "Water" entry you have to move your mouse out of the popup. Also, make sure to set the Real World Size value to the right size.(I scaled the cube down and used the longest side Z)

If you want to start the liquid inflow at a certain time, you can save yourself a lot cache by starting the simulation at that time, though the keys for the inflow you had already set, i started at 1 for convenience while testing.

So try and test around until you are happy and once it's looking fine, you can increase the resolution for more details if needed, then switch the "Domain Cache" Type to Final and press Bake All.

Updated with little explanation: The Domain in regards to liquid simulations takes the place of the liquid itself, but only for the time it is simulated as mesh. So if the simulation is running from frame 1 to 100 you must expect the domain cube to show up again from frame 101 onward. That problem can usually be solved by giving the simulation a bit more time to settle and then exchanging a still of the simulations last frame with the domain. The Object used for the inflow can be set invisible after the simulation is baked in mesh as the liquid will take it's place, except in case that the inflow is hidden anyway, like in a pipe or such.

Here two visual motivations: enter image description here enter image description here

Happy Blending

$\endgroup$
2
  • $\begingroup$ YES! After 3rd attempt i made it, it finally work. I don't know how you made it but thank you. Also could you explain me why the bounder is cube, but it is behaving like interior of the cup? And how did you make the cylinder vanish away when the inflow is closed? $\endgroup$ – KacperYZ Mar 22 '20 at 18:43
  • $\begingroup$ If you mean the bounding box in the last gif, that is the simcup, set to show as bounds, while the real object is a copy of the interior of the cup with the outer side removed and then solidify used on it. The cylinder is set to invisible from the start, what you see there is the liquid inflow that then stops. $\endgroup$ – Xylvier Mar 22 '20 at 20:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.