1
$\begingroup$

I'm trying to make an object that would keep some of the edges sharp, but it's causing a weird shading on the corners. How do I fix that, if I want to keep the bottom, the top and the side sharp (they're all marked).

I'm using the bevel modifier with limit method selected as weight. I tried to increase the segment count, recalculate normals. When I put a ngon here the problem got solved though. How do I fix that if I don't want any ngons in the mesh?

Thanks!enter image description here enter image description here enter image description here enter image description here

$\endgroup$
  • 2
    $\begingroup$ Did you try using "Harden Normals" in the Bevel Modifier, or in the Object Properties Tab under "Normals" the "Auto Smooth" option? $\endgroup$ – Xylvier Mar 21 at 15:02
  • $\begingroup$ Oops, tried auto smooth but not in combination with harden normals - fixed, thanks! $\endgroup$ – Drax Mar 21 at 17:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.