0
$\begingroup$

I've been working on a mesh and realised that part of it is not being shaded consistently across the borders of each quad. I've isolated the section into its own blend file and cannot figure out what's causing the issue.

The section in question is a flat plane with some loop cuts. It's set to flat shading and the face normals are all consistent and pointing in the same direction. There is no modifiers applied.

shading is not continuous across quads in a subdivided plane

Does anyone know the cause of this and how to correct it?

Blend file can be downloaded here: https://drive.google.com/file/d/1DW8WcC2wAT3FR1h9uUGkHZmDef-mzgR3/view?usp=sharing

$\endgroup$

2 Answers 2

2
$\begingroup$

While deactivating the "Auto Smooth" helps at the moment, i believe that something else happened and messed the normals up.

In my humble opinion i think that the surface should be fine even if the Normals are set to "Auto Smooth", in that regard i checked and found that if you press Alt+N and use the "Set From Faces" option, the surface normals are corrected.

Here the visual confirmation:

enter image description here

$\endgroup$
5
  • $\begingroup$ I agree... maybe something arround Alt+L... haven't find what exactly. $\endgroup$
    – lemon
    Mar 20, 2020 at 18:25
  • $\begingroup$ Interesting. I tried using the set from faces on the full mesh, and whilst it fixed the section in question it also messed up the normals elsewhere on the mesh. However, selecting Reset Vectors fixed it for the whole mesh. $\endgroup$
    – MrQuery
    Mar 20, 2020 at 18:43
  • $\begingroup$ To figure out how it happened is i believe rather impossible, as just one shortcut pressed the wrong modifier key, like alt instead of shift, and it goes under. I just tried to play with the Alt+L function and somehow even got the result, but then again trying to replicate it did not work. I only remember that i switched on spherize and it looked like the situation we started with here. At the same time i found a bug, Blender crashes if you are in the Alt+L function and press Tabulator. Gonna write a bug report, so be careful to safe before playing with the Alt+L function! $\endgroup$
    – Xylvier
    Mar 20, 2020 at 18:46
  • $\begingroup$ All functions regarding Normals are working on the selected elements, so yeah, different situations like beveled areas and such can and will differ in result with different normal functions. $\endgroup$
    – Xylvier
    Mar 20, 2020 at 18:48
  • $\begingroup$ It's entirely possible I hit Alt+L by accident, as I was selecting connected vertices with L not long before I noticed the issue. Thanks for your help! $\endgroup$
    – MrQuery
    Mar 20, 2020 at 18:53
1
$\begingroup$

'Autosmooth' is turned on:

Go to the 'object data properties' part, in the 'normals' section, and uncheck 'autosmooth'.

enter image description here

$\endgroup$
1
  • $\begingroup$ No idea how I mangaged to turn that on. Thanks for the quick answer! $\endgroup$
    – MrQuery
    Mar 20, 2020 at 17:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .