0
$\begingroup$

I made an object. It looks good in Blender, but if I export it into Unity, it is transparent, and I can see the parts of the Object that I should not see.

For Example In Blender: enter image description here

In Unity: enter image description here

How can I solve this problem?

$\endgroup$
1
$\begingroup$

To see faces which face the wrong way inside Blender go to the Shading top in the top right corner of the vieport and enable Backface Culling:

https://i.imgur.com/FMQHf4d.png

This is what it looks like:

https://i.imgur.com/p8whZZr.png

Now select the faces which are facing the wrong way, press Alt N and choose either recalculate Outside or recalculate Inside depending on what you need:

https://i.imgur.com/xOxltxQ.png

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.