1
$\begingroup$

Newish user here and appreciate any help I can get. I'm running into an issue where I can't seem to get my baked indirect lighting to show up in my viewport or render in Eevee.

After baking, the emission from these windows doesn't appear to light the interior of the room.

Windows with emission aren't lighting interior after baking

Here's what I've double checked:

  • The material I've created has an emission w/ enough power
  • Irradiance and Reflection cube map Probes are set up
  • I've clicked the bake indirect lighting button

The other weird note is that when I move the object with the emission material closer to the objects in the scene, it suddenly works as expected. I've included all of this in screenshots. Let me know if there's any other info that would be useful.

Emission works properly after changing y position

Here are my render settings also:

Render settings1 Render settings2

$\endgroup$
1
  • $\begingroup$ I followed the same course and I have the same exact problem, I don't have any hidden object blocking the light but I have the same exact lighting as your first screenshot, when I move the windows forward it isn't any better, are youre sure the issue was something occulting the light? Thanks :) $\endgroup$ Nov 15 '20 at 13:21
1
$\begingroup$

FACEPALM

Turns out I had an object hidden in viewport that was blocking the emission layer. Hiding that object in the viewport and render fixed everything!

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.