6
$\begingroup$

These are the settings of the flow object and the domain object.

enter image description here

enter image description here

I think I got all the settings right but every simulation I bake does not show the fluid. I tried restarting blender but it keeps doing this. I checked the 'liquid' tick box and it was enabled. I just can't see anything even the atom-like particles. What could be the problem?

$\endgroup$
3
  • 1
    $\begingroup$ Can you show us the entire blender windows with the domain selected and with the baking done? Or maybe give us the file so we can investigate ourselves. $\endgroup$
    – L0Lock
    Mar 14 '20 at 13:43
  • 1
    $\begingroup$ @L0Lock Here you go: imgur.com/a/eekL4km. $\endgroup$
    – 김준형
    Mar 14 '20 at 23:40
  • 1
    $\begingroup$ Did you make this work ? I am having same problem. Baking data, but no particles will display. $\endgroup$
    – angryITguy
    Jun 17 '20 at 4:43
3
$\begingroup$

Increase with the Resolution Diverges. Higher resolutions allow it to detect thinner, smaller objects. (For small objects, resolutions like 512+ may be needed and can take a while depending on your computer).

As well as baking the data, you also have to bake the mesh. Scroll down a little to get to the Mesh section:

Now bake the mesh.

$\endgroup$
1
  • 2
    $\begingroup$ I do not see this "Bake Mesh" option..... Any ideas? $\endgroup$
    – urema
    Jul 11 '20 at 11:52
2
$\begingroup$

Turn the cache type to Modular or Final (anything but Replay)

enter image description here

$\endgroup$
0
$\begingroup$

This problem has happened to me. Try changing resolution to 16 then back to 32 this will reset the thing and force it to render again. Also try saving to project

$\endgroup$
0
$\begingroup$

I have faced the same problem and I've solved it by setting the Surface Emission property to a non-zero value. You can find it by going to the Physics tab of the flow emitter object, scrolling to the Fluid modifier section (here Type will be Flow), then finding the Settings > Flow Source > Surface Emission field).

All tutorials I've watched either skip over the property completely or say that zero means the volume of the fluid will be that of the flow emitter object. I have not found this to be the case, at least not in Blender 2.91.0 which is what I'm using. I couldn't get the flow to show up no matter what I tried until I set this value to 1 and then it all magically worked.

$\endgroup$
0
$\begingroup$

Have you tried to give an initial velocity to you fluid in the correct direction?! same as this picture: adding velocity to the fluid in the phisics

$\endgroup$
1
  • $\begingroup$ as you can see, I have an inflow and gave an initial velocity to it! as far as I see in your picture, yours is zero, maybe that is the reason! good luck $\endgroup$
    – Man
    Dec 31 '20 at 13:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.