0
$\begingroup$

I have rigged my character with automatic weights, and everything seems OK except for a few faces which are left behind when I rotate the head. They are the faces that make up the iris and pupil in the eyes.

These faces were modelled separately to the rest of the eyes but they were joined to the eye objects so I don't know why they don't follow them! I'm not able to select them as separate objects, yet rotating the bones in pose mode leaves them behind as you can see in the image below.

gif if faces left behind when rotating bones

$\endgroup$
1
$\begingroup$

First of all put the armature modifier before the subsurf and check the two buttons of armature modifier so it acts in edit mode also.

As you can read in the N properties panel, the not moving vertices heve been weighted to the wrong bones (shoulder and upper arm), instead of "spine.006".

enter image description here

Then go to the vertex groups tab, select all wrong moving vertices, remove them from the wrong vertex groups, and assign them to the "spine.006" one.

enter image description here

In general, when an object has to move exactly with one bone, without any deformation, you should avoid automatic weighting, and parent the object directly to the bone (bone option, choose the bone in pose mode), or choose "with empty group" option and manually assign all vertices to the corresponding vertex group.

$\endgroup$
1
  • $\begingroup$ Thank you, it would have taken me a long time to figure that out! $\endgroup$ – petehallw Mar 15 '20 at 20:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.