0
$\begingroup$

I got a simulation of falling money, made from planes instanced by a particle system, combined into one object and then simulated as cloth.

Everything is basically working, but there are a couple of bills that I would like to hide from the render because of weird collision errors.

Problem is, I can't seem to figure out any kind of a way to access just these few objects to be able to hide them without having any other effect on the simulation.

enter image description here

$\endgroup$
4
  • $\begingroup$ select the mesh and press H to hide and alt+H to unhide back $\endgroup$
    – atek
    Mar 10, 2020 at 6:56
  • $\begingroup$ It's all one object remember, so I can't just select certain objects. and as soon as I enter edit mode, the simulation goes away and they go to their starting position, so you can't tell which ones are the problem ones. And I need to hide them in the render, not just the viewport. $\endgroup$
    – bowserlm
    Mar 10, 2020 at 14:26
  • $\begingroup$ To let money in appear in SIM more like a paper decrease grid topology. For bag use Simpler proxy model hidden from rendering. Those adjustmances Will improve sim, So you would not have to delete them. $\endgroup$
    – vklidu
    Aug 17, 2021 at 5:55
  • $\begingroup$ @Sanbaldo ('s) answer would be my first experiment also. Make a copy of your Blend file and play around with that, not your original. With your bank bills behaving differently, chances are you could get away with that. In earlier versions opening an emitter's cache tab and ticking the "External" box, loses the existing cache when exiting Blender. If you save the file and exit, when reloaded, the particles behave differently. The more recent versions may well do this also. $\endgroup$
    – Edgel3D
    Aug 17, 2021 at 5:57

2 Answers 2

0
$\begingroup$

What about adding some light force field (for example: wind) coming from the inside of the bag, just to avoid the collision of particles with the bag itself?

Here's a tutorial to manage the overlapping particles in Blender, not sure if it can help you.

You can also try to use the shader Particle Info Node, trying to identify the particle ID and setting a custom shader node (Transparent for example) for these particles.

$\endgroup$
3
  • $\begingroup$ check this node setup to find the ID of a particle: i.imgur.com/9kovhXW.png $\endgroup$
    – Sanbaldo
    Mar 10, 2020 at 17:07
  • $\begingroup$ I don't want to alter the simulation at all. Everything is as it should be excpet for about 4 of the bills that have problematic collisions. And the bills are no longer particles, they were just distributed using particles. They are all combined into one object with the Cloth Modifier. $\endgroup$
    – bowserlm
    Mar 10, 2020 at 20:02
  • $\begingroup$ if they are not anymore particles from emitter simulation, why can't you simply delete them? (edit mode). you can still try to apply custom materials (transparent) to that faces (using material slots). if you share your source file (or someting similar or modified if you don't want to share your original file), I can check it $\endgroup$
    – Sanbaldo
    Mar 11, 2020 at 10:10
0
$\begingroup$

A simple solution - why didn't I think of it back then? (March 2020)

The offending bills can simply be hidden by placing a duplicate of the emitter object in front of it. Lay it at whatever angle suits. Switch it to visible at the frame the offending one lands.

If the offending particles, for whatever reason, change their landing locations, simply move the extra bills and their dopesheet keyframes to hide them again.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .