7
$\begingroup$

In the images below, I have a cube that is sticking up about two thirds through a plane. But, despite the fact that the cube is not hovering over the plane, the shadow seems to indicate otherwise. How can I fix this shadow?

enter image description here enter image description here

$\endgroup$

1 Answer 1

11
$\begingroup$

Use 'contact shadows' (Eevee) in the lamp settings:

enter image description here

$\endgroup$
4
  • 2
    $\begingroup$ Wow ...why isn't this the default setting? $\endgroup$ Commented Mar 9, 2020 at 8:07
  • 5
    $\begingroup$ I don't know... maybe because Eevee is designed for speed and that adds calculations. $\endgroup$
    – lemon
    Commented Mar 9, 2020 at 8:09
  • 2
    $\begingroup$ It's not a default setting because contact shadows are view dependent. It can sometimes cause more problems like light bleed from outside of the camera frame :). $\endgroup$ Commented Jun 2, 2020 at 12:25
  • $\begingroup$ thanks for the information, @JachymMichal. $\endgroup$
    – lemon
    Commented Jun 2, 2020 at 18:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .