1
$\begingroup$

See if you can help me figure out what’s going on with this basic chair geometry with normals issues.

enter image description here

I recalculate normals and—still have a normals problem.

enter image description here

I check the face orientation. Ok, a little mismatching.

enter image description here

I manually flip the normals but STILL the problem persists. (I tried both red and blue sides to be sure).

enter image description here

So I try an experiment: manually deleting the faces and re-adding them. I delete a face, select the adjacent edges and hit F to create a face.

enter image description here

Still a problem with normals.

enter image description here

I try this again but this time selecting all four edges before hitting F to creating a face. Fixed normals—and this works for all the faces. Can someone help me understand why this is?

enter image description here

  1. Why are the Recalculate Normals and Flip Normals functions not working here?
  2. Why must I select all four edges to create a working face? Selecting two edges is (technically) selecting all four vertices,is it not?
  3. Obviously to go about deleting and re-adding every face is needlessly time-consuming to repeat across the entire mesh. How do I go about this correctly?

Thank you for your time,

John

$\endgroup$
  • 1
    $\begingroup$ Hello :). My bet is on some double vertices. Have you tried Object > Clean Up > Merge by distance? $\endgroup$ – Jachym Michal Mar 4 at 16:30
  • $\begingroup$ Hey, great idea but I had that thought too—and I found no double verts (and I adjusted the threshold). $\endgroup$ – John Mar 4 at 17:37
  • 4
    $\begingroup$ Well, since I'm obviously not good at guessing, would you mind sharing the .blend file? :) $\endgroup$ – Jachym Michal Mar 4 at 17:55
  • $\begingroup$ Here it is, thank you: <img src="https://blend-exchange.giantcowfilms.com/embedImage.png?bid=ExwdnSMw" /> $\endgroup$ – John Mar 4 at 22:46
  • $\begingroup$ Also, just so you’re aware, when I add a bevel modifier to the mesh (which is where my noticing this problem began) it behaves asymmetrically, so it really seems like a mesh problem but for whatever reason, I simply can’t locate one? $\endgroup$ – John Mar 4 at 22:53
2
$\begingroup$

The mesh has some inside faces, and Blender is confused by it :).

  1. Select the inside faces through Select > All by trait > Inside Faces
  2. Delete them with X > Faces
  3. Done.

enter image description here

Credits to @John for finding the best solution for his own problem :).

| improve this answer | |
$\endgroup$
  • 1
    $\begingroup$ Excellent. Interior faces were the problem and I never had thought of or used the Non-Manifold selection tool (for me it was under Select > Interior Faces, perhaps renamed in the latest build). Thank you kindly. $\endgroup$ – John Mar 5 at 12:42
  • $\begingroup$ You're right! Select > Interior faces is way faster, thanks for pointing that out :). I just couldn't make it work at first... $\endgroup$ – Jachym Michal Mar 5 at 12:58
1
$\begingroup$

Three more things to check since you already tried remove doubles/Merge by distance

  • is it because of smooth shading on flat object ?
  • go in edit mode with vertex select mode and see if there are extra vertices on any edges (You wont see extra vertices in edge or face select mode)
  • In Face edit mode check if there are overlapping faces which did not get merged using remove doubles (Just keep clicking a face in wireframe mode ....if there are two faces you'll see the shading changing on each click)
| improve this answer | |
$\endgroup$
  • $\begingroup$ It is smooth shading on a flat surface, although I do have auto smooth enabled, which shouldn’t be an issue. However, to add a bit to the mystery—when beveling, it behaves asymmetrically. Strange because I tried your other two bits of advice to no avail. I attached the .blend to an above comment if you’d be interested in taking a look yourself. Thank you for your assistance :) $\endgroup$ – John Mar 4 at 22:50
0
$\begingroup$

I downloaded your blend file

With blender 2.82.

Go into edit mode

Enabling face orientation

enter image description here

Select all

Shift + N to recalculate normals

enter image description here

Select the face that's still not having the right face orientation

Shift + N to recalculate normals

Then select inside

enter image description here

| improve this answer | |
$\endgroup$
  • $\begingroup$ This was something I show and explain as not working in my question. Looking at your screenshots, it appears as though it didn’t work for you either. Thank you for your time, regardless. $\endgroup$ – John Mar 5 at 12:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.