0
$\begingroup$

I've been working on this file for a while with no problems, until now. In Material Preview mode all my objects appear bright white, apart from the trees at the back, which are black. All the other viewports seem to be working as they should and i can still render an image with all materials in place. I just cant see them anymore in Material Preview. enter image description here

$\endgroup$
4
  • $\begingroup$ That's weird. Could you save a new file, pack the textures in File > External Data > Pack All Into .blend (increases file size a bit) - And put the .blend here please: blend-exchange.giantcowfilms.com (and edit the code bit to this post, so we can download it) - would help immensely with troubleshooting $\endgroup$ Commented Mar 4, 2020 at 11:11
  • 1
    $\begingroup$ I've tried to upload it a couple of times but it seems to stall once it gets to about 75%. I have however spent the time waiting clicking a 100 different bottoms, and I don't know which did the trick but I've got it back working. Thank you for trying to help @ManuJärvinen $\endgroup$
    – Ruth
    Commented Mar 4, 2020 at 12:22
  • $\begingroup$ Oh man, I wonder if the packed .blend is too large. If it's under 30MB, you can upload it here: pasteall.org/blend and then post the link to it - OH, you got it working, nice one! Too bad if you can't post the solution for the ones who could need it :/ $\endgroup$ Commented Mar 4, 2020 at 12:24
  • 1
    $\begingroup$ Yeah i was wondering if it was too large. Not sure whats considered too large though. This file is over 30MB but its a good tip for future issues. Thanks $\endgroup$
    – Ruth
    Commented Mar 4, 2020 at 12:29

2 Answers 2

2
$\begingroup$

Happens to me too, I usually solve this way:

Select EEVEE as renderer if it's not already, then go to Indirect Lighting and Delete Lighting Cache, then bake it again.

At this point switch between shading view modes, it should get fixed.

We should probably mark this as a bug, not 100% sure about it but looks like it.

enter image description here

$\endgroup$
1
  • $\begingroup$ This worked for me, but I had to bake indirect lighting first and then delete lighting cache. Thank you so much, I would have never of found this EVER. $\endgroup$
    – Dominic M.
    Commented Apr 19, 2020 at 6:05
0
$\begingroup$

I tried a lot of ways about this topic. And I tried this too but it didn't work. Now I solve the problem. The problem was closing the High quality normals setting. After I opened that setting up my problem got solved.

$\endgroup$
1
  • 1
    $\begingroup$ Where can this option be found? Could you elaborate to make your answer more complete? $\endgroup$ Commented Jan 10, 2021 at 23:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .